Bug 1850395 - Affinity modal crashes when user tries to change Operator from the select dropdown
Summary: Affinity modal crashes when user tries to change Operator from the select dro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 08:47 UTC by Radim Hrazdil
Modified: 2021-01-02 19:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:09:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5821 0 None closed Bug 1850395: Affinity modal crashes when user tries to change Operator 2021-01-02 19:25:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:20 UTC

Description Radim Hrazdil 2020-06-24 08:47:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):
OCP 4.5.0 rc.1
CNV 2.4
UI running locally from current master

How reproducible:
100%

Steps to Reproduce:
1. Create example VM, Open Affinity modal, add Affinity rule
2. add node label  Key: 'test' Operator: DoesNotExists , save, save
3. Open affinity moda, edit the rule, change the Operator from DoesNotExists
 to In

Actual results:
Uncaught TypeError: Cannot read property 'length' of undefined

Expected results:


Additional info:

Comment 1 Radim Hrazdil 2020-06-24 08:56:10 UTC
@Gilad, FYI it is possible that this issue was introduced by fix for BZ1848418

Comment 2 Yaacov Zamir 2020-06-24 09:09:42 UTC
^^

Comment 5 Guohua Ouyang 2020-06-30 10:21:03 UTC
verified on upstream 4.6 branch

Comment 7 errata-xmlrpc 2020-10-27 16:09:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 8 Gilad Lekner 2021-01-02 19:26:57 UTC
Clearing redundant NEEDINFO


Note You need to log in before you can comment on or make changes to this bug.