Bug 1850417 - Need bump the default channel to stable-4.6
Summary: Need bump the default channel to stable-4.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.6.0
Assignee: W. Trevor King
QA Contact: liujia
URL:
Whiteboard:
: 1854430 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 09:35 UTC by liujia
Modified: 2020-10-27 16:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:09:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3848 0 None closed Bug 1850417: data/manifests/bootkube/cvo-overrides: Bump default to stable-4.6 2021-01-18 02:28:43 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:26 UTC

Description liujia 2020-06-24 09:35:34 UTC
Description of problem:
For v4.6 latest build, we need bump the default channel to stable-4.6(now is still stable-4.5).
https://github.com/openshift/installer/blob/release-4.6/data/data/manifests/bootkube/cvo-overrides.yaml.template


# ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-06-24-005232   True        False         4h17m   Cluster version is 4.6.0-0.nightly-2020-06-24-005232

# ./oc get clusterversion -ojson|jq .items[].spec
{
  "channel": "stable-4.5",
  "clusterID": "00a3542a-989b-4125-aa84-014c2a2bc41f",
  "upstream": "https://api.openshift.com/api/upgrades_info/v1/graph"
}


Version-Release number of the following components:
4.6.0-0.nightly-2020-06-24-005232

How reproducible:
always

Steps to Reproduce:
1. Install ocp v4.6 with latest v4.6 build
2.
3.

Actual results:

Expected results:
Default channel of v4.6 cluster should be stable-4.6

Additional info:
https://github.com/openshift/installer/blob/release-4.6/data/data/manifests/bootkube/cvo-overrides.yaml.template#L8

Comment 3 Abhinav Dahiya 2020-07-07 16:29:02 UTC
*** Bug 1854430 has been marked as a duplicate of this bug. ***

Comment 4 liujia 2020-07-13 02:35:06 UTC
Verified on 4.6.0-0.nightly-2020-07-12-232219

# ./oc get clusterversion -ojson|jq .items[].spec
{
  "channel": "stable-4.6",
  "clusterID": "75e54dfd-3f14-4055-86af-167f8b9234df",
  "upstream": "https://api.openshift.com/api/upgrades_info/v1/graph"
}

Comment 6 errata-xmlrpc 2020-10-27 16:09:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.