Bug 185106 - initrd not being created with clean i386 net install of 3/10/06 rawhide
Summary: initrd not being created with clean i386 net install of 3/10/06 rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 185187 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-03-10 18:09 UTC by Clyde E. Kunkel
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-12 15:36:00 UTC
Type: ---


Attachments (Terms of Use)
install log. Lots of scriplet errors. (74.13 KB, text/plain)
2006-03-10 18:29 UTC, Clyde E. Kunkel
no flags Details
per request - anaconda ks file (2.04 KB, text/plain)
2006-03-10 19:45 UTC, Clyde E. Kunkel
no flags Details
now, per request (38.26 KB, text/plain)
2006-03-10 19:54 UTC, Clyde E. Kunkel
no flags Details
per request (82.09 KB, text/plain)
2006-03-10 19:55 UTC, Clyde E. Kunkel
no flags Details
last one, per request (57.38 KB, text/plain)
2006-03-10 19:55 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2006-03-10 18:09:05 UTC
Description of problem:

Filing against anaconda, may be something else.

Apparently normal i386 net install of 3/10/06 rawhide on LVs over software raid5
until firstboot when msg:  Kernel panic - not syncing: VFS: unable to mount root
fs on unknown-block (0,0).

Looked at /boot and there isn't any initrd. And, no entry for an initrd img in
grub.conf.

Tried another mirror, then tried a minimal install from
download.fedora.redhat.com, same result both times.

Noted the following msg in console 1 during all install attempts:  error:
rpmtsOrder failed, 133 elements remain.

During one of the attempts and just before rebooting for firstboot, went to
console 2, chrooted to /mnt/sysimage and tried /sbin/mkinitrd
initrd-2.6.15-1.2038_FC5smp 2.6.15-1.2038_FC5smp.  Got error that said:
/sbin/mkinitrd: line 35: /etc/rd.d/init.d/functions: no such file or directory.
Looked into /etc/rd.d/init.d and indeed no functions, but don't know how selinux
is affecting what I do at this point.


Version-Release number of selected component (if applicable):
rawhide of 3/10/06

How reproducible:
every time


Steps to Reproduce:
1. Create net install boot CD with boot.iso
2. Boot CD, select HTTP install, select mirror
3. Selection options, including custom partitioning for / on an LV, format;
/boot on /dev/hda17, format; /home on an LV, NOFORMAT
4. Select packages, watch install of packages
5. Select boot at end of package install

  
Actual results:

Kernel panic as above on firstboot


Expected results:
Normal first boot and continue with rest of install.

Additional info:

Have been doing daily installs of rawhide during this period of getting ready
for FC5 release.  Use same methods and try to use identical selections and
keystrokes for each one.

Comment 1 Clyde E. Kunkel 2006-03-10 18:29:13 UTC
Created attachment 125952 [details]
install log.  Lots of scriplet errors.

Comment 2 Jeremy Katz 2006-03-10 18:53:52 UTC
Can you also grab /var/log/anaconda*?   I'll kick off an install here, but I
don't think we've seen that today.

Comment 3 Clyde E. Kunkel 2006-03-10 19:45:33 UTC
Created attachment 125956 [details]
per request - anaconda ks file

Comment 4 Clyde E. Kunkel 2006-03-10 19:54:35 UTC
Created attachment 125957 [details]
now, per request

Comment 5 Clyde E. Kunkel 2006-03-10 19:55:21 UTC
Created attachment 125958 [details]
per request

Comment 6 Clyde E. Kunkel 2006-03-10 19:55:58 UTC
Created attachment 125959 [details]
last one, per request

Comment 7 G.Wolfe Woodbury 2006-03-10 21:39:33 UTC
Also seen here.  The rpmtsOrder bug was seen before and resulted in the kernel
not being installed by anaconda. Now the kernel gets installed, but hte initrd
is missing and with ext3 being a module, the kernel fails when trying to get
stuff from the ext3 filesystem on the root.

Comment 8 Chris Lumens 2006-03-10 21:44:22 UTC
This was caused by a policycoreutils packaging problem that was creating a
dependancy cycle we weren't breaking.  So, ordering was failing and only a
subset of all packages were being installed.  Fixed in packaging, and looking at
ways we can detect problems like this before the last possible minute.

Comment 9 Clyde E. Kunkel 2006-03-11 15:12:36 UTC
Problem still present with clean net install of rawhide of (3/11/06) tho initrd
image is now being created.

Should this be a new bug report?  Looks like same problem with different symptions.

Boot msgs (hand transcribed):
<snip>
Write protecting the kernel read-only data: 365K
Failed to execute /init
Kernel panic - not syncing: no init found. Try passing init= option to kernel.
<snip error data>

Console 1 showed before initial boot: error: rpmtsOrder failed, 141 elements remain.

/root/install.log shows voluminous scriplet errors.

Comment 10 Clyde E. Kunkel 2006-03-12 15:36:00 UTC
Clean net install of 3/12/06 rawhide works.  No rpmtsOrder error.

Comment 11 Jeremy Katz 2006-03-12 21:55:46 UTC
*** Bug 185187 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.