Bug 185112 - logout / logout dialogs no longer asks to save the session
logout / logout dialogs no longer asks to save the session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 191526 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 13:58 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 13:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-03-10 13:58:15 EST
The logout (and shutdown) dialogs used to have a checkbox wether or not to save
the session. This checkbox is gone now, and I kinda miss it, especially since
there is no other way (that I know of) to save the current session.

Without this checkbox the only way to save the session is to select
"Automatically save changes" in gnome-session-properties, which is not what I want.

Also gnome-session-properties still contains a sak on logout checkbox, but no
matter what value this is given, the logout dialogs will not ask to save the
session.
Comment 1 Matthias Clasen 2006-03-11 09:56:22 EST
Hans, you can run gnome-session-save to save the current session.
I don't know whats up with the check box, though. 
Comment 2 Matthias Clasen 2006-03-11 10:04:27 EST
Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=330500
Comment 3 Hans de Goede 2006-03-11 10:23:36 EST
Matthis, thanks for the hint. I think it would be nice if there was a menu entry
for this somewhere, maybe under a save session entry under the preferences menu?

Comment 4 Gérard Milmeister 2006-03-27 10:50:15 EST
(In reply to comment #2)
> Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=330500
Hmm, not related to this bug, I would think.
Comment 5 Erik P. Olsen 2006-03-28 16:37:27 EST
In System->Preferences->More Preferences->Sessions you can set "Automatically
save changes to session". According to the help text this will perform the
session save without prompt. However, it also states that if this option is NOT
set then a prompt at logout will ask whether to save the session or not.

This prompt never happens and I believe that this is the real bug.
Comment 6 Doug Ledford 2006-08-22 16:00:47 EDT
(In reply to comment #4)
It's related, but only because of interpretation issues.  Some people are
interpreting session options->Ask on Logout to mean "Ask me if I want to log
out" when checked and "Log out immediately without confirmation dialog" if
unchecked, where as the people in this bug report are still interpreting this
based upon the old, established behavior which was "Ask me if I want to save my
session state on the logout/shutdown dialog" when checked or "Don't clutter up
the logout/shutdown dialog" when unchecked.  Upstream could make the issue a
little more clear by doing something like:

Save Session:
  ( )  Automatically on logout/shutdown
  ( )  Ask me on logout/shutdown
  ( )  Never

in the save session dialog box.  That would make the usage/intent of the "Ask on
logout" option clear.  Then to make the people in the upstream bug report happy,
they could do a different option, say "Confirm logout/shutdown?" for having a
confirmation dialog at all.

Note, this bug still applies to Fedora Core 6 Test 2.
Comment 7 Ray Strode [halfline] 2006-08-22 16:22:27 EDT
So we don't use the logout dialog in gnome-session anymore.  We use one from the
panel.

Soeren is going to commit some changes at some point to 

1) get rid of the first two tabs in gnome-session-properties
2) get rid of the ctrl-alt-delete patch to metacity to make the gnome-session
dialog pop up
3) flip some gconf schema defaults such that the dialog never pops up  (even if
you do gnome-session-save --kill)
Comment 8 Matthias Clasen 2006-08-22 22:59:28 EDT
I am not convinced that removing the first 2 tab is a good idea.
Comment 9 Ray Strode [halfline] 2006-08-23 11:20:07 EDT
The second tab should be merged into gnome-system-monitor.

Multiple session support was an interesting idea that never really worked right.
Comment 10 Matthias Clasen 2006-08-23 12:48:38 EDT
This sounds like a good plan, that would also allow us to fix some issues in
gnome-system-monitor, like ending gnome-panel, only to see it come back immediately
Comment 11 Olivier Baudron 2006-09-14 10:42:19 EDT
*** Bug 191526 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Roesen 2006-10-29 11:08:39 EST
Well, the problem still persists in FC6 release (as in FC5). I simply am not
able to save a default session state that opens a couple of gnome-terminals at
certain places without using the "auto-save session" option. If I do use this
auto-save option it works, but as soon as I disable the auto-saving again, the
session is hosed.

Effectively this problem prevents me from upgrading from FC4 to FC6 (and earlier
to FC5) on my desktop and laptop - I need a consistent startup session (so
cannot keep auto-save enabled).

Although those issues seem to be two different ones, they might have a common
root cause - I'm not into GNOME session management. I just want to a save a
startup desktop setup with a couple of gnome-terminals opening in the right
positions and dimensions.

Any clues when we'll get this fixed?

Best regards,
Daniel
Comment 13 Ray Strode [halfline] 2006-10-29 19:04:34 EST
Can you uncheck "Auto save session", create the configuration you want,
press alt-f2, type gnome-session-save (press enter)?

I realize this is a workaround...
Comment 14 Daniel Roesen 2006-10-29 22:15:27 EST
Thanks Ray, this workaround works for me.

Now searching for a brightside replacement which enables me to switch desktops
by pushing the mouse pointer against the desktop edges. :-)
Comment 15 Ray Strode [halfline] 2007-03-28 13:40:32 EDT
the session preferences capplet now has a "Save current session" button.

Note You need to log in before you can comment on or make changes to this bug.