Bug 1851675 - open pkg/graphql/schema.graphql: no such file or directory
Summary: open pkg/graphql/schema.graphql: no such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1851890 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-28 05:40 UTC by Junqi Zhao
Modified: 2020-10-27 16:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:09:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5843 0 None open Bug 1851675: Include graphql schema in downstream docker build 2020-06-29 08:56:57 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:10:06 UTC

Description Junqi Zhao 2020-06-28 05:40:02 UTC
Description of problem:
console is degraded, that makes the installation failed
# oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version             False       True          167m    Unable to apply 4.6.0-0.nightly-2020-06-28-022022: the cluster operator console is degraded

# oc -n openshift-console get pod
NAME                         READY   STATUS             RESTARTS   AGE
console-56c64f4867-dxkgw     0/1     CrashLoopBackOff   34         149m
console-56c64f4867-xp9v9     0/1     CrashLoopBackOff   33         149m
console-7fc5f455c8-qcvft     0/1     CrashLoopBackOff   32         144m
downloads-85c98ccd4f-d8bgk   1/1     Running            0          153m
downloads-85c98ccd4f-f94cf   1/1     Running            0          153m


# oc -n openshift-console logs console-56c64f4867-dxkgw
2020-06-28T05:35:11Z cmd/main: cookies are secure!
panic: open pkg/graphql/schema.graphql: no such file or directory

goroutine 1 [running]:
github.com/openshift/console/pkg/server.(*Server).HTTPHandler(0xc000274c00, 0xc000274c00, 0xc000308180)
	/go/src/github.com/openshift/console/pkg/server/server.go:246 +0x32aa
main.main()
	/go/src/github.com/openshift/console/cmd/bridge/main.go:591 +0x288d


Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-06-28-022022

How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.6
2.
3.

Actual results:
console is degraded

Expected results:
no error

Additional info:

Comment 1 hongyan li 2020-06-29 06:21:53 UTC
Tried build 4.6.0-0.nightly-2020-06-29-003953, the issue is still there.

Comment 2 Jakub Hadvig 2020-06-29 08:34:21 UTC
Assigning to Rastislav since he was in charge of the Add GO GraphQL Server PR - https://github.com/openshift/console/pull/5316

Comment 3 Jakub Hadvig 2020-06-29 12:02:13 UTC
*** Bug 1851890 has been marked as a duplicate of this bug. ***

Comment 6 Junqi Zhao 2020-06-30 04:34:40 UTC
fixed with 4.6.0-0.nightly-2020-06-30-000342
# oc get co/console
NAME      VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
console   4.6.0-0.nightly-2020-06-30-000342   True        False         False      133m
# oc -n openshift-console get pod
NAME                        READY   STATUS    RESTARTS   AGE
console-788b79dbcc-2zzgb    1/1     Running   0          133m
console-788b79dbcc-6mxnl    1/1     Running   0          133m
downloads-5cf6d8447-7ms5n   1/1     Running   0          143m
downloads-5cf6d8447-btgpx   1/1     Running   0          143m
# oc -n openshift-console logs console-788b79dbcc-6mxnl
2020-06-30T02:14:17Z cmd/main: cookies are secure!
2020-06-30T02:14:17Z cmd/main: Binding to [::]:8443...
2020-06-30T02:14:17Z cmd/main: using TLS

Comment 8 errata-xmlrpc 2020-10-27 16:09:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.