Bug 1852321 - Cluster Settings page still show 4.5 upgrade channels
Summary: Cluster Settings page still show 4.5 upgrade channels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-30 06:39 UTC by Yadan Pei
Modified: 2020-10-27 16:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:10:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5857 0 None closed Bug 1852321: List 4.6 upgrade channels for OCP 4.6 2020-10-28 10:46:17 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:10:55 UTC

Description Yadan Pei 2020-06-30 06:39:12 UTC
Description of problem:
on Cluster Setting page, we still show stable-4.5, fast-4.5 and candidate-4.5 channels on OCP 4.6

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-06-26-035408

How reproducible:
Always

Steps to Reproduce:
1. admin user check upgrade channels on a OCP 4.6 cluster at Administration->Cluster Settings
2.
3.

Actual results:
1. The channels are still: stable-4.5, fast-4.5 and candidate-4.5

Expected results:
1. For OCP 4.6, we should list stable-4.6, fast-4.6 and candidate-4.6 upgrade channels

Additional info:

Comment 3 Yanping Zhang 2020-07-07 03:43:52 UTC
Checked on 4.6 cluster with payload 4.6.0-0.nightly-2020-07-06-180619。
On Cluster Settings page, it shows stable-4.5 for the first glance, check the channel list, there are stable-4.6, fast-4.6, candidate-4.6 in the list. After choose one eg "stable-4.6", the channel is set to "stable-4.6".
It's better set the channel to stable-4.6 instead of stable-4.5 by default after cluster is ready.

Comment 4 Jakub Hadvig 2020-07-07 13:33:32 UTC
This is a issue of installer, not ManagementConsole, since Console does not set the channel by default.
Created a separate bug for that - https://bugzilla.redhat.com/show_bug.cgi?id=1854430

Comment 5 Yanping Zhang 2020-07-08 02:56:27 UTC
According to Comment 4, the original issue is fixed, so move the bug to Verified.

Comment 7 errata-xmlrpc 2020-10-27 16:10:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.