Bug 1852473 - [v2v][VM import from RHV to CNV][UI] 2 nics are mapped to a new network though second was mapped to pod.
Summary: [v2v][VM import from RHV to CNV][UI] 2 nics are mapped to a new network thoug...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 4.6.0
Assignee: Filip Krepinsky
QA Contact: Igor Braginsky
URL:
Whiteboard:
Depends On:
Blocks: 1852530
TreeView+ depends on / blocked
 
Reported: 2020-06-30 13:53 UTC by Filip Krepinsky
Modified: 2020-10-27 16:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Nics which had the same nic profile could not be imported successfully or wrong network would be chosen. Fix: The UI forces users to select the same network(which is not pod network ) for such nics
Clone Of:
: 1852530 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:10:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5871 0 None closed Bug 1852473: kubevirt: fix importing VMs with same vnicIDs for ovirt provider 2020-10-30 14:43:06 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:11:08 UTC

Description Filip Krepinsky 2020-06-30 13:53:49 UTC
This bug was initially created as a copy of Bug #1850482

I am copying this bug because: it affects UI part as well



Description of problem:
Import a VM with 2 ovirtmgmt/ovirtmgmt nics on RHV side.
In UI VM import wizard, map the 2 networks as follows (attachment "network map setting screenshot"):
nic1: Name: ovn-kubernetes1  Type: bridge (Set by default and can't be changed) 
nic2: Pod Networking Type: masquerade (Set by default and can't be changed)

The VM import is resulted with setting network ovn-kubernetes1 to both nics 
(attachment "network map outcome screenshot").
 
Version-Release number of selected component (if applicable):
CNV-2.4

How reproducible:
Same behavior Repeated on 3 trials.

Comment 2 Yaacov Zamir 2020-07-01 14:19:35 UTC
setting priority high because IIUC this is customer related

Piotr please keep me honest here ?

Comment 3 Piotr Kliczewski 2020-07-02 07:29:19 UTC
@Kobi From my perspective I would like to see it backported to stable branch. From my perspective it is still urgent.

Comment 6 Yaacov Zamir 2020-07-20 08:36:30 UTC
@Ilanit hi, 

This BZ blocks https://bugzilla.redhat.com/show_bug.cgi?id=1852530 , it is important for us to get it verified so we can unblock 1852530, can you prioritize it for verification before other bugs we have ?

Comment 7 Yaacov Zamir 2020-07-20 09:50:55 UTC
@Ilanit thanks,

In an off line discussion we found out that we currently do not have an env to test this BZ, and this BZ will be tested as soon as an env will be available.

Comment 8 Amos Mastbaum 2020-08-04 10:25:25 UTC
Will be verified as soon as we have 4.6 2.5 env

Comment 9 Igor Braginsky 2020-10-05 13:42:36 UTC
Couldn't reproduce this bug in CNV 2.5, both NICs were bound to proper networks according to configuration in migration wizard

Comment 11 errata-xmlrpc 2020-10-27 16:10:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.