Bug 1852889 - The minKubeVersion should be 1.18.3
Summary: The minKubeVersion should be 1.18.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Periklis Tsirakidis
QA Contact: Giriyamma
URL:
Whiteboard:
Depends On: 1859614
Blocks: 1842446
TreeView+ depends on / blocked
 
Reported: 2020-07-01 14:13 UTC by Anping Li
Modified: 2020-10-27 16:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:11:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 586 0 None closed Bug 1852889: Bump minKubeVersion to 1.18.3 2020-08-21 20:57:18 UTC
Github openshift cluster-logging-operator pull 608 0 None closed Revert "Bug 1852889: Bump minKubeVersion to 1.18.3" 2020-08-21 20:57:19 UTC
Github openshift cluster-logging-operator pull 623 0 None closed Bug 1852889: Revert "Merge pull request #608 from periklis/revert-minkubeversion-1-18-3" 2020-08-21 20:57:19 UTC
Github openshift elasticsearch-operator pull 414 0 None closed Bug 1852889: Bump minKubeVersion to 1.18.3 2020-08-21 20:57:18 UTC
Github openshift elasticsearch-operator pull 428 0 None closed Revert "Bug 1852889: Bump minKubeVersion to 1.18.3" 2020-08-21 20:57:19 UTC
Github openshift elasticsearch-operator pull 434 0 None closed Bug 1852889: Revert "Merge pull request #428 from periklis/revert-minkubeversion-1-18-3" 2020-08-21 20:57:19 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:12:05 UTC

Description Anping Li 2020-07-01 14:13:28 UTC
Description of problem:
The Clusterlogging 4.6 couldn't be deployed on OCP 4.4.  It seems the root cause is Kubernetes-1.17.1 doesn't support apiextensions.k8s.io/v1 which is used in clusterlogforwarders.logging.openshift.io.

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. deploy cluster logging 4.6 on OCP 4.4


Actual results:
The CLO pod couldn't be started.

Expected results:


Additional info:

Comment 1 Periklis Tsirakidis 2020-07-06 07:18:48 UTC
Put UpcomingSprint, this is a pending feature for 4.6.

Comment 5 Periklis Tsirakidis 2020-07-21 11:18:48 UTC
Need to reopen this BZ and save the bump to 1.18.3 for a later stage on the 4.6 development cycle. The APIserver on our upstream CI is still 1.17 and this requirement is blocking E2E tests for both operators.

Comment 7 Periklis Tsirakidis 2020-07-22 06:51:07 UTC
Back to Assigned because we need to take back the reverts after CI is on >1.19 again.

Comment 9 Anping Li 2020-07-30 15:10:17 UTC
Verify on latest bundles.

Comment 11 errata-xmlrpc 2020-10-27 16:11:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.