Bug 1854166 - Audio playback on USB audio dongle very slow and distorted
Summary: Audio playback on USB audio dongle very slow and distorted
Keywords:
Status: CLOSED DUPLICATE of bug 1852564
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-06 15:48 UTC by Michael Wiktowy
Modified: 2020-07-06 18:34 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-06 18:34:23 UTC
Type: Bug


Attachments (Terms of Use)
dmsg of kernel with slow audio (113.55 KB, text/plain)
2020-07-06 15:48 UTC, Michael Wiktowy
no flags Details
Output of 'lsusb -v' for USB audio dongle (34.10 KB, text/plain)
2020-07-06 15:49 UTC, Michael Wiktowy
no flags Details

Description Michael Wiktowy 2020-07-06 15:48:08 UTC
Created attachment 1700046 [details]
dmsg of kernel with slow audio

1. Please describe the problem:

I upgraded the kernel and audio through my USB sound card plays back extremely slowly causing video playback to be slow also. This happens in Youtube or videos played in the Gnome video player. It is also audible in system error sounds.

2. What is the Version-Release number of the kernel:

Issue is present in latest released kernel 5.7.7-200.fc32 but I went back and installed older kernels and the first occurence of issue is in kernel 5.7.6-200.fc32. 

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Last good kernel downloaded from Koji was kernel 5.7.5-200.fc32. The audio issue is not present when I installed and booted into this kernel


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Yes. Install or upgrade to released kernel beyond version 5.7.5-200 and playback any audio/video source. Audio (and video if present) plays back at a 1/8th speed (I measured 10s of audio as displayed by the player took 80s to play back).

I have tried plugging the UGreen USB audio dongle into other ports but problem persists.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Not sure.

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No closed source modules

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

See attached dmsg.txt

Comment 1 Michael Wiktowy 2020-07-06 15:49:17 UTC
Created attachment 1700048 [details]
Output of 'lsusb -v' for USB audio dongle

Comment 2 Evan McClain 2020-07-06 17:20:07 UTC
Looks like upstream bugreport is here: https://bugzilla.kernel.org/show_bug.cgi?id=208403

I'm having similar issues with audio through my Dell dock or magewell usb capture device. My laptop's internal sound card is still working though.

Comment 3 Michael Wiktowy 2020-07-06 17:42:40 UTC
There is a similar issue with laptop docks in Bug 1852564 but I wasn't sure if it was related so I opened a new one since this is a stand-alone USB audio adapter ( https://www.amazon.com/UGREEN-Adapter-External-Stereo-Headset/dp/B06XP5R449 ). Maybe there is a common cause.

Comment 4 Hans de Goede 2020-07-06 18:34:23 UTC
Thank you for the bug report this indeed seems to be the same issue as bug 1852564. The plan is to wait for upstream to come up with an official fix for this and then we will add that to the Fedora kernels ASAP.

In the mean time the best workaround is to use an older kernel for now.

*** This bug has been marked as a duplicate of bug 1852564 ***


Note You need to log in before you can comment on or make changes to this bug.