Bug 1852564 - ThinkPad Dock USB Audio distorted [NEEDINFO]
Summary: ThinkPad Dock USB Audio distorted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1853707 1854166 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-30 17:34 UTC by Dimitris
Modified: 2020-07-15 18:43 UTC (History)
34 users (show)

Fixed In Version: kernel-5.7.8-200.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-12 01:01:00 UTC
Type: Bug
hdegoede: needinfo? (jforbes)


Attachments (Terms of Use)
kernel log (124.40 KB, text/plain)
2020-06-30 17:42 UTC, Dimitris
no flags Details

Description Dimitris 2020-06-30 17:34:20 UTC
1. Please describe the problem:

When selecting:

!!Soundcards recognised by ALSA
!!-----------------------------

...

3 [Audio          ]: USB-Audio - ThinkPad Dock USB Audio
                      Generic ThinkPad Dock USB Audio at usb-0000:06:00.3-4.2.4, high speed

the sound sounds extremely distorted, not really recognizable as the audio that's playing.  Other audio outputs (laptop speakers, analog wired headset, different USB headset) play back fine.

In fact the separate USB headset that still works is connected to the same USB hub:

2 [C60            ]: USB-Audio - AIAIAI C60
                      AIAIAI AIAIAI C60 at usb-0000:06:00.3-4.4, full speed


2. What is the Version-Release number of the kernel:

5.7.6-201.fc32.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Yes, this is the first kernel version that has this issue.  Kernels since F31 and up to/including 5.6.19-300.fc32 worked with this output without problems.  Booting back to 5.6.19 makes the issue disappear.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Reproduces 100%, both on fresh boot and after suspend/resume.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Haven't tried rawhide yet.

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Dimitris 2020-06-30 17:42:07 UTC
Created attachment 1699372 [details]
kernel log

Comment 2 bjoern.daase 2020-07-01 09:30:18 UTC
I can confirm this problem with the Dell WD 15 dock.  

Furthermore, the 5.7.4-200.fc32.x86_64 kernel actually also works well for me, so the problem must bei introduced between 5.7.4 und 5.7.6. I hope that helps to bisect the problem

Comment 3 Dimitris 2020-07-02 05:38:34 UTC
I still see this under 5.7.7-200.  There were a number of changes under ALSA usb-audio in the 5.7.7 changelog but at least on my hardware there's no change.

Comment 4 Tomas Knot 2020-07-02 16:51:08 UTC
Also I can confim this problem with kernel 5.7.4-200.fc32.x86_64. I have dock a Lenovo TP Port ThinkPad PRO dock 2018 with Thinkpad T490.

Comment 5 Yann Soubeyrand 2020-07-04 14:21:51 UTC
Same here on a ThinkPad T480 with USB-C docking station.

This bug has been reported upstream:
- https://bugzilla.kernel.org/show_bug.cgi?id=208311
- https://bugzilla.kernel.org/show_bug.cgi?id=208317
- https://bugzilla.kernel.org/show_bug.cgi?id=208353 (this one contains a fix from the author of the commit which introduced the bug).

Until a new version of the kernel with a fix is packaged, is there a way to pin the kernel and still upgrade the rest of the system on Silverblue?

Comment 6 Hans de Goede 2020-07-04 17:07:03 UTC
*** Bug 1853707 has been marked as a duplicate of this bug. ***

Comment 7 Silvio Marazzato 2020-07-04 17:51:14 UTC
Same problem with Dell Latitude 7490, Dell WD 15 dock and kernel version 5.7.6-201.
Booting back to 5.6.19-300 makes the issue disappear.

Comment 8 Franz H. 2020-07-05 21:54:33 UTC
Same problem with Fujitsu U749 and the Port-Replicator.

Comment 9 c.riess.dev 2020-07-06 10:30:36 UTC
I can also confirm with Kernel 5.7.7-200.fc32 and a Thinkpad dock with USB Audio ID 17ef:306f

Comment 10 Hans de Goede 2020-07-06 18:34:23 UTC
*** Bug 1854166 has been marked as a duplicate of this bug. ***

Comment 11 Florian Engelhardt 2020-07-07 08:29:47 UTC
I can confirm this problem on a Dell Inc. XPS 15 7590 (BIOS 1.7.0 05/11/2020) with the Dell WD 19 TB Dock.

Audio-Out and Line-Out on the Dock are both slow motion sound. Audio-Out on the Laptop itself works as expected.

Bug appears in 5.7.7-200.fc32.x86_64 and 5.7.6-201.fc32.x86_64

Bug disappears when switching back to Kernel 5.6.19-300.fc32.x86_64

Comment 12 Silvio Marazzato 2020-07-07 08:40:15 UTC
The problem also persists with kernel 5.7.7-200 on Dell Latitude 7490 and Dell WD 15 dock.

Comment 13 Hans de Goede 2020-07-07 12:58:00 UTC
A fix (revert of the commit causing the trouble) has been queued for being added to:

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/?h=linux-5.7.y

Note it has been queued, not pushed yet, but it should show up really soon there now.

Justin, depending on the timing of 5.7.8 (I expect that will come real soon now) we may want to cherry-pick the revert and do an extra 5.7.7-x01 build with just that revert, as quite a lot of users are affected by this issue.

And either way (cherry-pick or wait for 5.7.8) the bodhi update should be set to close this bug.

Comment 14 Florian Engelhardt 2020-07-07 13:42:21 UTC
BTW: I compiled 5.7.7-200.fc32.x86_64 with the upstream test patch from https://bugzilla.kernel.org/show_bug.cgi?id=208353 applied and can confirm it solves the problem for me.

Comment 15 Dimitris 2020-07-10 05:46:52 UTC
The 5.7.8 build on testing https://bodhi.fedoraproject.org/updates/FEDORA-2020-3c3d1d7006 contains the revert of the commit that broke this, and fixes the issue for me.

Comment 16 Fedora Update System 2020-07-10 13:41:35 UTC
FEDORA-2020-3c3d1d7006 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3c3d1d7006

Comment 17 Fedora Update System 2020-07-12 01:01:00 UTC
FEDORA-2020-3c3d1d7006 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Christian Krause 2020-07-15 18:43:30 UTC
I suffered from the same issue in Fedora 31 (with kernel-5.7.7-100.fc31.x86_64). The update to kernel 5.7.8 (https://bodhi.fedoraproject.org/updates/FEDORA-2020-3be4990c1d - currently in updates-testing) fixes the issue in F31, too.


Note You need to log in before you can comment on or make changes to this bug.