Bug 1854643 - Tabs on pod details page are not clickable
Summary: Tabs on pod details page are not clickable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.6.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1854749 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-07 20:05 UTC by Samuel Padgett
Modified: 2020-10-27 16:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.ci-2020-07-06-163355 Cluster ID: 1c01e75c-944d-46e5-a655-45916fa70281 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:79.0) Gecko/20100101 Firefox/79.0
Last Closed: 2020-10-27 16:12:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Tabs and breadcrumbs are not clickable (4.23 MB, video/quicktime)
2020-07-08 10:59 UTC, Jakub Hadvig
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5925 0 None closed Bug 1854643: Fix bug where sortable table header buttons can overlay … 2020-07-13 03:07:13 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:06 UTC

Description Samuel Padgett 2020-07-07 20:05:05 UTC
None of the tabs on the pod details page respond to clicks. This appears to be a regression with the Patternfly update. I believe somehow it's triggering a sort of the Volumes table much further down the page.

Comment 1 Jakub Hadvig 2020-07-08 10:59:59 UTC
Created attachment 1700278 [details]
Tabs and breadcrumbs are not clickable

Also the breadcrumbs are effected based on https://bugzilla.redhat.com/show_bug.cgi?id=1854749 which is a duplicate issue.

Comment 2 Jakub Hadvig 2020-07-08 11:00:26 UTC
*** Bug 1854749 has been marked as a duplicate of this bug. ***

Comment 3 Samuel Padgett 2020-07-08 15:55:27 UTC
Marking this urgent as it breaks many other pages in console that have tables.

Comment 4 Samuel Padgett 2020-07-08 16:00:17 UTC
This seems to affect any page that uses a *non* virtualized table (like pod details and home -> explore).

Comment 5 Robb Hamilton 2020-07-09 12:27:25 UTC
Waiting on QE verification.

Comment 8 XiaochuanWang 2020-07-13 03:10:27 UTC
Check on different kinds of resources, tab pages can now clickable without issue.
Verified on 4.6.0-0.nightly-2020-07-12-204440

Comment 10 errata-xmlrpc 2020-10-27 16:12:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.