Bug 185526 - Provide a meaningful vgck implementation
Provide a meaningful vgck implementation
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.7
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Rockai
Corey Marthaler
: FutureFeature
: 248191 576686 (view as bug list)
Depends On:
Blocks: 182355
  Show dependency treegraph
 
Reported: 2006-03-15 10:19 EST by Alasdair Kergon
Modified: 2012-10-10 16:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 16:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2006-03-15 10:19:27 EST
(ref. bug 168723)
Comment 1 Dave Wysochanski 2007-03-12 13:10:03 EDT
Since no one has claimed this one, and I have been looking at recovery of
metadata and the code paths are similar, I'll take this for now.
Comment 2 Dave Wysochanski 2010-05-17 08:15:24 EDT
Moving to rhel5.
Comment 3 Milan Broz 2010-06-23 11:34:04 EDT
*** Bug 576686 has been marked as a duplicate of this bug. ***
Comment 4 Milan Broz 2010-06-23 11:34:29 EDT
*** Bug 248191 has been marked as a duplicate of this bug. ***
Comment 5 Zdenek Kabelac 2010-11-24 17:11:04 EST
Looks to my like Petr's domain for now.
Comment 6 Petr Rockai 2010-11-30 18:00:32 EST
It may be my domain, but it would be useful to know what is vgck supposed to do. It does what the manpage says it does, but I agree it's not entirely useful since all other vg-related commands run the same checks anyway. So what is the meaning of this bug?

I can see 3 possible coures of action:
1) Get a clear picture of what vgck should do, retitle and repurpose this bug to that end.
2) Decide that vgck is redundant and remove it (although it's not *entirely* redundant anymore, I think it "fails" (gives error code) in more cases than vgs).
3) Do nothing and close this BZ as NOTABUG.

I am setting this to needinfo for now, in the hope of going with option 1 (as I don't have any ideas myself). If no-one comes up with anything, I'll fall back to option 3.
Comment 9 RHEL Product and Program Management 2012-10-10 07:49:35 EDT
Thank you for submitting this issue for consideration. Red Hat Enterprise Linux 5 has reached the end of Production 1 Phase of its Life Cycle.  Red Hat does not plan to incorporate the suggested capability in a future Red Hat Enterprise Linux 5 minor release. If you would like Red  Hat to re-consider this feature request and the requested functionality is not currently in Red Hat Enterprise Linux 6, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.
Comment 10 Petr Rockai 2012-10-10 16:11:46 EDT
Since 1) failed, going with 3).

Note You need to log in before you can comment on or make changes to this bug.