This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248191 - vgck appears to be of no use when vg is actually corrupted
vgck appears to be of no use when vg is actually corrupted
Status: CLOSED DUPLICATE of bug 185526
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.7
All Linux
low Severity low
: ---
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 15:43 EDT by Corey Marthaler
Modified: 2010-06-23 11:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 11:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-07-13 15:43:00 EDT
Description of problem:
vgck fails just like any other lvm cmd when there is an actual corruption. So
what's the point of this cmd? 

[root@link-08 ~]# vgck helter_skelter

Corrupt a vg by writing over a pv in that vg:
[root@link-08 ~]# dd if=/dev/zero of=/dev/sdf1 count=1000
1000+0 records in
1000+0 records out
[root@link-08 ~]# sync

[root@link-08 ~]# vgck helter_skelter
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Volume group "helter_skelter" not found

[root@link-08 ~]# vgs
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Couldn't find device with uuid 'XEpeSh-dIcc-Z3kg-4kYv-kpdH-bvbH-1BO8rF'.
  Couldn't find all physical volumes for volume group helter_skelter.
  Volume group "helter_skelter" not found
  VG         #PV #LV #SN Attr   VSize  VFree
  VolGroup00   1   2   0 wz--n- 74.41G 32.00M

Version-Release number of selected component (if applicable):
lvm2-2.02.21-5.el4
Comment 1 Dave Wysochanski 2009-12-08 17:26:02 EST
I have another bz for vgck so I'll see if I can't make this command do something more useful in the near future.
Comment 2 Dave Wysochanski 2010-05-17 08:13:11 EDT
No upstream fix in rhel4 - moving to rhel5.
Comment 3 Milan Broz 2010-06-23 11:34:29 EDT

*** This bug has been marked as a duplicate of bug 185526 ***

Note You need to log in before you can comment on or make changes to this bug.