Bug 18553 - Bug owner does not get updated when the component is changed
Bug owner does not get updated when the component is changed
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
: 15516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 13:27 EDT by Doug Ledford
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 16:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2000-10-06 13:27:44 EDT
If a new bug is submitted to bugzilla on kernel component, and then I
determine that it isn't a kernel bug but an installer bug, and I switch the
component to installer, bugzilla does not update the default component
owner when the switch is made.  In my case, I was switching the component
on a bug still marked as new and not assigned to anyone, so bugzilla needs
to make sure to re-assign the default owner so that the default package
owner gets and email about the bug and knows to take care of it.
Comment 1 Doug Ledford 2000-10-06 13:28:36 EDT
oops, I had the wrong Bugzilla version in the bug report, updated to the correct
version for what we are running currently...
Comment 2 David Lawrence 2000-10-06 13:35:05 EDT
Currently when changing the component of a bug report it only does just that,
changes the component. All other information is not touched unless specified. I
would need to put a button under say the component list box saying something
like "Also change owner to owner of new component" for this to be done
correctly. Because sometimes people would not want the owner changed
automatically. I will look into this as a feature request. Until then you can
also just change the component like always and then additionally type the new
owners name in the "Assign bug to" text field at the bottom before submitting
the change. This will unfortunately mean you would have to know the owners email
address of the new component yourself but that can be gotten by clicking on the
word "Component" next to the component list which will show all components and
owners for the current product.
Comment 3 Doug Ledford 2000-10-06 13:51:19 EDT
I disagree.  At least, as long as the bug is still status==NEW, then changing
the component should change the default owner automatically.  The reason is that
the bug hasn't been accepted as assigned yet, so in order for the right person
to look at it (after the component is changed), they have to be notified.  Right
now, they aren't.  If someone submits a bug under kernel, but it's really just
that some module was left out of the install disk instead, then it's not a
kernel bug, it's an installer bug.  So, I change the component to installer. 
That's fine, I can do that.  Right now I also have to assign it to msw or else
put msw on the Cc: list in order for the bug to get noticed by the install
people.  That's bad.  If I assign it, then I'm assuming that it's a legitimate
bug without really knowing so since I'm not an installer person.  If I add msw
to the Cc: list, then that still leaves me in the default owner position and I
still get email about it even though I've passed it off.

Now, if the bug has been assigned, then I can agree with your statement, but as
long as the bug is new, I think the default should be changed.  Aka, doing the
following sometime before putting together the email list would be my
suggestion:

if ((status==NEW) && (new_component != old_component))
	new_default_owner = default_owner(new_component);

Comment 4 David Lawrence 2000-10-06 13:56:14 EDT
Good point that I had not taken into consideration. That seems like a good
policy to stick with as long as the NEW status doesnt go away I dont mind
hardcoding this conditional in. I doubt the NEW status will ever change to
something different. This should not take much to implement.
Comment 5 Aleksey Nogin 2002-11-13 05:52:38 EST
*** Bug 15516 has been marked as a duplicate of this bug. ***
Comment 6 Maxwell Kanat-Alexander 2003-12-16 13:24:26 EST
You know, this has actually been handled in the current Bugzilla,
since that "reassign to component owner" button exists.

-M
Comment 7 David Lawrence 2005-08-23 16:38:46 EDT
Please reopen and change version to 2.18 if this problem still occurs with the
latest release of Bugzilla.

Note You need to log in before you can comment on or make changes to this bug.