Bug 18558 - Developmental Version of GCC included in RH7.0 not compatable with Past or Future Versions
Developmental Version of GCC included in RH7.0 not compatable with Past or Fu...
Status: CLOSED DUPLICATE of bug 18585
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 14:15 EDT by pugfantus
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 14:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pugfantus 2000-10-06 14:15:09 EDT
On Thu, 05 Oct 2000 18:58:11 Gerald Pfeifer wrote:
It has come to our attention that some GNU/Linux distributions are
currently shipping with ``GCC 2.96''.

We would like to point out that GCC 2.96 is not a formal GCC release nor
will there ever be such a release.  Rather, GCC 2.96 has been the code-
name for our development branch that will eventually become GCC 3.0.

Current snapshots of GCC, and any version labeled 2.96, produce object
files that are not compatible with those produced by either GCC 2.95.2
or
the forthcoming GCC 3.0.  Therefore, programs built with these snapshots
will not be compatible with any official GCC release.  Actually, C and
Fortran code will probably be compatible, but code in other languages,
most notably C++ due to incompatibilities in symbol encoding
(``mangling''),
the standard library and the application binary interface (ABI), is
likely
to fail in some way.  Static linking against C++ libraries may make a
binary more portable, at the cost of increasing file size and memory
use.

To avoid any confusion, we have bumped the version of our current
development branch to GCC 2.97.

Please note that both GCC 2.96 and 2.97 are development versions; we
do not recommend using them for production purposes.  Binaries built
using any version of GCC 2.96 or 2.97 will not be portable to systems
based on one of our regular releases.

If you encounter a bug in a compiler labeled 2.96, we suggest you
contact whoever supplied the compiler as we can not support 2.96
versions that were not issued by the GCC team.

Please see http://gcc.gnu.org/snapshots.html if you want to use our
latest snapshots.  We suggest you use 2.95.2 if you are uncertain.

The GCC Steering Committee <http://gcc.gnu.org/steering.html>
Comment 1 Jakub Jelinek 2000-10-07 11:39:27 EDT

*** This bug has been marked as a duplicate of 18585 ***

Note You need to log in before you can comment on or make changes to this bug.