Bug 1856803 - Cluster monitoring documentation link is broken - 404 not found
Summary: Cluster monitoring documentation link is broken - 404 not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1856948 1904600 1929920
TreeView+ depends on / blocked
 
Reported: 2020-07-14 13:35 UTC by Ilya Buziuk
Modified: 2021-02-17 23:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixed a broken link to the cluster monitoring documentation from the web console OperatorHub install page.
Clone Of:
: 1929920 (view as bug list)
Environment:
Last Closed: 2021-02-17 23:02:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Reproducer (199.73 KB, image/gif)
2020-07-14 13:35 UTC, Ilya Buziuk
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5984 0 None closed Bug 1856803: Fix incorrect monitoring doc link 2021-02-15 15:41:46 UTC
Github openshift console pull 7426 0 None closed Bug 1856803: Fix cluster monitoring link 2021-02-15 15:41:46 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:52 UTC

Description Ilya Buziuk 2020-07-14 13:35:35 UTC
Created attachment 1701033 [details]
Reproducer

Description of problem:

Version-Release number of selected component (if applicable): OCP 4.4


How reproducible:


Steps to Reproduce:
1. Install operator with the 'operatorframework.io/cluster-monitoring: true' label e.g. https://github.com/eclipse/che-operator/pull/339
2. Navigate to the `cluster monitoring documentation link` 
3. ERROR - 404 docs not found

Actual results:

404 


Expected results:

Link point to the valid documentation


Additional info:

See the gif attached

Comment 1 Samuel Padgett 2020-07-14 13:39:16 UTC
Note that we don't show the warning for Red Hat operators, so this only affects non-Red Hat operators.

Comment 4 XiaochuanWang 2020-07-15 06:31:41 UTC
This links to https://docs.openshift.com/container-platform/<version>/monitoring/cluster_monitoring/configuring-the-monitoring-stack.html#maintenance-and-support_configuring-monitoring and the page existed.
Verified on 4.6.0-0.nightly-2020-07-14-224428

Comment 6 errata-xmlrpc 2020-10-27 16:14:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 7 Ilya Buziuk 2020-11-17 11:41:14 UTC
The issue is still reproducible against the latest OCP 4.6 - docs point to the https://docs.openshift.com/container-platform/4.6/monitoring/cluster_monitoring/configuring-the-monitoring-stack.html#maintenance-and-support_configuring-monitoring which return 404

Comment 9 Samuel Padgett 2020-11-17 13:34:44 UTC
Looks like we have an extra `cluster_monitoring` in the path.

Comment 12 Yadan Pei 2020-12-09 09:29:35 UTC
1. Install operator with the 'operatorframework.io/cluster-monitoring: true' label e.g Metering
2. Navigate to the `cluster monitoring documentation link`, it points to https://docs.openshift.com/container-platform/4.7/monitoring/configuring-the-monitoring-stack.html#maintenance-and-support_configuring-monitoring, when I replace 4.7 with 4.6, docs are loaded correctly thus the link is correct 


Moving to VERIFIED and this is checked against 4.7.0-0.nightly-2020-12-08-141245

Comment 13 Luke Meyer 2021-02-17 23:02:40 UTC
(In reply to errata-xmlrpc from comment #6)
> Since the problem described in this bug report should be
> resolved in a recent advisory, it has been closed with a
> resolution of ERRATA.
> 
> If the solution does not work for you, open a new bug report.

This is not just friendly advice. Once a bug has shipped in an advisory, it can never ship again. If it's not fixed, OPEN A NEW BUG.

I cloned the bug appropriately; returning now to its correct state.


Note You need to log in before you can comment on or make changes to this bug.