Bug 1856948 - Cluster monitoring documentation link is broken - 404 not found
Summary: Cluster monitoring documentation link is broken - 404 not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1856803
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 18:34 UTC by OpenShift BugZilla Robot
Modified: 2020-08-10 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixed a broken link to the cluster monitoring documentation from the web console OperatorHub install page.
Clone Of:
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (60.25 KB, image/png)
2020-07-31 06:32 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5990 None closed [release-4.5] Bug 1856948: Fix incorrect monitoring doc link 2020-08-07 17:43:28 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:44 UTC

Description OpenShift BugZilla Robot 2020-07-14 18:34:28 UTC
+++ This bug was initially created as a clone of Bug #1856803 +++

Created attachment 1701033 [details]
Reproducer

Description of problem:

Version-Release number of selected component (if applicable): OCP 4.4


How reproducible:


Steps to Reproduce:
1. Install operator with the 'operatorframework.io/cluster-monitoring: true' label e.g. https://github.com/eclipse/che-operator/pull/339
2. Navigate to the `cluster monitoring documentation link` 
3. ERROR - 404 docs not found

Actual results:

404 


Expected results:

Link point to the valid documentation


Additional info:

See the gif attached

--- Additional comment from spadgett@redhat.com on 2020-07-14 13:39:16 UTC ---

Note that we don't show the warning for Red Hat operators, so this only affects non-Red Hat operators.

Comment 3 XiaochuanWang 2020-07-31 06:32:47 UTC
Created attachment 1703041 [details]
Verification screenshot

Comment 4 XiaochuanWang 2020-07-31 06:34:19 UTC
Verified on 4.5.0-0.nightly-2020-07-30-020337
Elastic Search operator installer has the correct doc link "https://docs.openshift.com/container-platform/4.5/monitoring/cluster_monitoring/configuring-the-monitoring-stack.html#maintenance-and-support_configuring-monitoring"
Attached the Installation page screenshot for refer.

Comment 6 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.