Bug 1857095 - file detects some Word docx files as zip files rather than the more specific Microsoft OOXML type
Summary: file detects some Word docx files as zip files rather than the more specific ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: file
Version: 8.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 8.4
Assignee: Vincent Mihalkovič
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 1845169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-15 06:43 UTC by Raman Gupta
Modified: 2021-06-15 08:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-14 07:30:08 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Docx demonstrating the issue (10.62 KB, application/zip)
2020-07-15 06:43 UTC, Raman Gupta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
CentOS 17585 0 None None None 2020-07-15 06:43:09 UTC

Description Raman Gupta 2020-07-15 06:43:10 UTC
Created attachment 1701153 [details]
Docx demonstrating the issue

Description of problem:

The version of `file` RHEL 7.8 (version 5.11) does not detect all Word docx files properly. It detects some docx files as zip files.

The problem is apparently fixed in file 5.19.


Version-Release number of selected component (if applicable):

file 5.11


How reproducible:

Easily


Steps to Reproduce:
1. Take the attached file and run `file` on it.

Actual results:

It will report "Zip archive data, at least v1.0 to extract"


Expected results:

It should report "Microsoft OOXML"

Comment 2 manuel wolfshant 2020-07-15 07:53:13 UTC
It seems the bug is not present in CentOS 6

[wolfy@wolfy ~]$ file /tmp/docx-test-zip.docx
/tmp/docx-test-zip.docx: Zip archive data, at least v1.0 to extract
[wolfy@wolfy ~]$ rpm -q file
file-5.11-36.el7.x86_64

[wolfy@wolfy2 tmp]$ file docx-test-zip.docx
docx-test-zip.docx: Microsoft OOXML
[wolfy@wolfy2 tmp]$ rpm -q file
file-5.04-30.el6.x86_64

Comment 3 Kamil Dudka 2020-07-15 08:07:06 UTC
It is too late to fix this bug in RHEL-7 but it is going to be fixed in RHEL-8 (bug #1845169).  If you are a customer of Red Hat, please contact Product Support and tell them about this bug report.

Comment 4 Raman Gupta 2020-07-15 13:47:38 UTC
Why can't it be fixed in RHEL-7? Isn't it a supported platform? This bug causes issues with software that uses `file`, such as amavisd.

Comment 5 Kamil Dudka 2020-07-15 14:13:54 UTC
Technically, this can be fixed but it needs a strong business justification.  The deadline for putting this into RHEL-7.9 is already missed and no further minor updates of RHEL-7 are planned.

Comment 6 Kamil Dudka 2020-11-06 17:37:30 UTC
It is too late to fix this in RHEL-7.  The bug in question is fixed in RHEL-8 though.  Closing NEXTRELEASE.

Comment 7 Raman Gupta 2020-12-14 19:17:47 UTC
I just tried this on Centos 8 Stream. As I understand all the messaging around Stream, if this is fixed in RHEL-8, this should be fixed in Steam also. However:

```
# cat /etc/os-release 
NAME="CentOS Stream"
VERSION="8"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="8"
PLATFORM_ID="platform:el8"
PRETTY_NAME="CentOS Stream 8"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:8"
HOME_URL="https://centos.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux 8"
REDHAT_SUPPORT_PRODUCT_VERSION="CentOS Stream"

# file --version
file-5.33

# file docx-test-zip.docx 
docx-test-zip.docx: Zip archive data, at least v1.0 to extract

```

The same test file detects corretly on Fedora 32 with file version 5.38.

Comment 9 Kamil Dudka 2020-12-15 08:15:05 UTC
Indeed, the reproducer for this bug is different and the fix for bug #1845169 does not address it.  Thank you for pointing it out!  Let's move this bug to RHEL-8 to get it fixed eventually.

Comment 11 RHEL Program Management 2021-06-14 07:30:08 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.

Comment 12 Raman Gupta 2021-06-14 21:13:11 UTC
What, why? This is clearly a bug with a simple reproducer -- why in the world would it not be fixed?

Comment 13 Kamil Dudka 2021-06-15 08:29:22 UTC
Because not all reported bugs are fixed in Red Hat Enterprise Linux.  We prioritize bugs reported by our customers.  If you are a customer of Red Hat, please contact Product Support and tell them about this bug report.


Note You need to log in before you can comment on or make changes to this bug.