Bug 18571 - anaconda crashes when activating swap spaces
anaconda crashes when activating swap spaces
Status: CLOSED DUPLICATE of bug 17791
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 16:56 EDT by Dave Strickland
Modified: 2007-04-18 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 13:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Strickland 2000-10-06 16:56:05 EDT
Hi,

Anacondo is crashing during formatiing or activating the swap space on my
system.
Here is all the diagnostic text it produced....

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in
doInst
all
    self.fstab.turnOnSwap()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 406, in
turnOn
Swap
    isys.swapon (file)
  File "/usr/lib/anaconda/isys.py", line 142, in swapon
    return _isys.swapon (path)
SystemError: (1, 'Operation not permitted')

Local variables in innermost frame:
path: /tmp/swap/hdb7

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

The system is a dual 866 Mhz PIII, VIA Tiger 133 motherboard with 2 Maxtor 
40 Gb 7200rpm disks, 1 Gb PC133 SDRAM.  I used fdisk to set up both disks
as follows...

hda1 (primary) cyls 1 to 1023 linux native
hda2 (primary) +128M linux swap
hda3 (primary) approx 2300 cylinders linux native
hda4 (extended), contains
	hda5 128M swap
	hda6 128M swap
	hda7 128M swap
	hda8 128M swap
	hda9 rest of disk - linux native.

And similarly for the second disk. I ask the installer to format all
partitions and check
for bad blocks, then sit back and wait for six hours...

The installer then crashes. Flicking through the virtual consoles shows the
format
and bad-blocks checking went OK. The cntrl-alt-F4 virtual terminal shows
only
8 of the 10 swap partitions have been activated (I assume - it has eight
lines saying
activating swap priority -1 etc etc through -8).

Any quick fixes? 

Thanks
Dave
Comment 1 Rickard Hammarberg 2000-10-07 18:26:25 EDT
Almost the same for me, directly after it has fomated the swap space it crashes
and gives me this report.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 2 Dave Strickland 2000-10-07 18:35:37 EDT
Tried again using just four 256M swap partitions, but it crashed at the same
point
again...
Comment 3 Dave Strickland 2000-10-08 14:14:26 EDT
OK, I seem to have been able to work around it. Not sure why though.

Yesterday I tried using 4 sets of 256M swap partitions on hda. The install
went as normal, formatted the linux native partitions, mentioned it was
adding swap at priorities -1, -2 etc to -4 (this is on virtual console F4)
and then crashes.

Today I did everything exactly the same, except I didn't ask for any of
the linux native partitions to be formated at all (as they've be done
yesterday).
Pressing the next button brings up a small info window which says something
like "formatting swap space on /dev/hda7" (this is the last of the 4 swap spaces
I asked for) and then it goes straight into the package install. Everything
runs fine, and I now have a fully functioning system that I can log into.
All the swap seems to be activated and functions OK.

The only thing I can think of is maybe the installs I did previously didn't
format
all the swap spaces, perhaps leaving off the last on. When anaconda tries to
activate them it falls over when it gets to the last (unformatted) one.
Thati s purely speculation though... Anyway, I've got a work around so
I'm happy for now.

Cheers,
Dave

Comment 4 Konstandinos A. Saipas 2000-10-08 19:45:30 EDT
I had exactly the same problem, but unfortunatelly it did not work even when I 
instructed the installer to not format the partitions.  The output is as 
follows:Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/dos

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


I really look forward to having a solution as long as I cannot install RedHat 
due to this problem.

TIA.
Comment 5 Michael Fulbright 2000-10-09 11:46:25 EDT
To saipman@eexi.gr:

 Your problem is a dupe of 18032 and not related to the problem with swap space.
Comment 6 Michael Fulbright 2000-10-09 13:56:58 EDT
This is a dupe of  bug 17791.

I have tried to reproduce this case several times and I haven't been successful.
If everyone who has seen this bug could please attach details of their system,
including how they partitioned their drive(s) and the mount points they were
using,  it would perhaps help us track down this issue.

Also it would be good to know which partitions you chose to format, and if you
decided to check for bad blocks or not.


*** This bug has been marked as a duplicate of 17791 ***
Comment 7 Need Real Name 2000-10-09 14:26:28 EDT
Hello one of the systems that I'm seing this happen is on Dual PIII 700MHz on a 
SOYO main board, 512Mb ram, 2 30Gb harddrive, hda1 completely vfat, hdb was 
brokendown the following way: /= 8000 MB, /p2 = 8000 MB, /p3 = 8000 MB, /p4 = 
the remainder of the 30 GB.  I found a workaround to this on another bug that I 
commented on today I forget the Bug #. The workaround was to simply not mount 
any VFAT partitions durring the Install just simply leave it for after the 
Install. This can be done by editing the /etc/mtab file.

Note You need to log in before you can comment on or make changes to this bug.