Bug 18574 - swat does not work
swat does not work
Status: CLOSED DUPLICATE of bug 17839
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 17:39 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-11 12:52:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 17:39:24 EDT
swat does not start using "http://localhost:901" or "xxx.xxx.xxx:901" 
local or over the network.

httpd works
/etc/services has the correct entry for swat
/etc/xinetd.d/swat looks great

Looking at the logs for inetd, it does not even show any error message or 
that it tried to launch swat.  If I telnet to the machine, it logs just 
fine.  

Where do I go from here?
Comment 1 kjt99 2000-10-09 14:08:59 EDT
i have the same problem with swat and webaccess linuxconf, i added my host then
added a subnet and cant get swat or linuxconf to work, i did remove the diaable
= yes line in the etc/xinetd/linuxconf-web and /etc/xinetd/swat files

thanx
kjt
Comment 2 Panic 2000-10-10 18:27:56 EDT
We've (actually Nalin) traced this to a possible bug in the internal tcpwrappers
implementation of xinetd (I think I got that right).  You need to set up your
/etc/hosts.allow and /etc/hosts.deny to prevent access from everywhere, then
comment out this line in your /etc/xinetd.d/swat file:

only_from = localhost

That'll get SWAT going for the time being -- a fix is in the works.

Panic
Comment 3 Panic 2000-10-11 12:52:14 EDT
I've also been told that changing the line like this works as well:

only_from = localhost

to

only_from = 127.0.0.1

A name resolution problem?
Comment 4 Bill Nottingham 2000-10-16 12:51:56 EDT

*** This bug has been marked as a duplicate of 17839 ***

Note You need to log in before you can comment on or make changes to this bug.