Bug 1857424 - lib-bucket-provisioner v2 upgrade attempt to install both v1 and v2
Summary: lib-bucket-provisioner v2 upgrade attempt to install both v1 and v2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Vu Dinh
QA Contact: Bruno Andrade
URL:
Whiteboard:
: 1856990 (view as bug list)
Depends On:
Blocks: 1855706 1859493
TreeView+ depends on / blocked
 
Reported: 2020-07-15 20:27 UTC by Vu Dinh
Modified: 2021-03-18 17:57 UTC (History)
25 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1859178 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:14:43 UTC
Target Upstream Version:
wwurzbac: needinfo-
bandrade: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1642 0 None closed Bug 1857424: fix(resolver): Exclude all installed packages in dependency search 2021-02-08 10:56:21 UTC
Red Hat Bugzilla 1855706 1 None None None 2021-06-01 08:47:16 UTC
Red Hat Knowledge Base (Solution) 5221881 0 None None None 2020-07-24 03:56:41 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:15:04 UTC

Internal Links: 1859178

Description Vu Dinh 2020-07-15 20:27:40 UTC
Description of problem:
When the OCS 4.4 is installed, the dependent operator lib-bucket-provisioner v1 will be installed. However, when lib-bucket-provisioner v1 is upgrading to v2, there are multiple duplicate InstallPlans that attempts to install both lib-bucket-provisioner v1 and v2.

Version-Release number of selected component (if applicable):
OCS 4.4
OCP 4.4.9+

How reproducible:
100%

Steps to Reproduce:
1. Install OCS 4.4 in OCP 4.4.9+ cluster in Manual approval mode
2. Manually approve the initial InstallPlan (inspect the steps will see only OCS 4.4 and lib-bucket v1 are included).

Actual results:
Multiple new InstallPlans are generated and waiting for approval.
Inspect those InstallPlans and will see they have steps (CSV) for lib-bucket v1 and v2.

Expected results:
The lib-bucket v2 will not be installed as it requires 2 CRDs that are owned by a previous version of itself (lib-bucket v1) and that is NOT allowed. There shouldn't be any InstallPlans generated for lib-bucket v2 installation. The expectation is when OCS 4.5 is released, it will own the CRDs in question and lib-bucket will be able to upgrade to v2.

Additional info:
See linked BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=1855706

Comment 6 Bruno Andrade 2020-07-22 14:48:11 UTC
LGTM, marking as VERIFIED

Cluster info:
OCP: 4.6.0-0.nightly-2020-07-22-052714 
OLM version: 0.16.0
git commit: 14bfbf803cb5ce6f63f65c18a83b0c48ebc12148
OCS 4.4.1 installed with Manual Approval

As expected, only lib-bucket-provisioner.v1.0.0 was installed and v2 was rejected, only the respective InstallPlans were created

oc get ip 
NAMESPACE           NAME            CSV                             APPROVAL   APPROVED
openshift-storage   install-2h58f   ocs-operator.v4.4.1             Manual     true
openshift-storage   install-5rkbg   lib-bucket-provisioner.v2.0.0   Manual     false


oc get csv -n openshift-storage                                              
NAME                            DISPLAY                       VERSION   REPLACES   PHASE
lib-bucket-provisioner.v1.0.0   lib-bucket-provisioner        1.0.0                Succeeded
ocs-operator.v4.4.1             OpenShift Container Storage   4.4.1                Succeeded


oc get pods -n openshift-storage                                                                                                                    
NAME                                     READY   STATUS    RESTARTS   AGE
lib-bucket-provisioner-95f6c779b-z6z86   1/1     Running   0          11m
noobaa-operator-7d59dd58d7-wbrsd         1/1     Running   0          11m
ocs-operator-69f57fdd-4n2cr              1/1     Running   0          11m
rook-ceph-operator-55dfcc5dbc-66gh2      1/1     Running   0          11m

Comment 8 Vu Dinh 2020-07-24 03:56:42 UTC
*** Bug 1856990 has been marked as a duplicate of this bug. ***

Comment 17 errata-xmlrpc 2020-10-27 16:14:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.