Bug 185814 - 2054 kernel build missing symbols (print_tainted)
2054 kernel build missing symbols (print_tainted)
Status: CLOSED DUPLICATE of bug 185384
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 13:35 EST by Alex Stewart
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-19 19:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Stewart 2006-03-18 13:35:15 EST
Description of problem:

I just updated to the 2.6.15-1.2054 kernel, rebuilt a proprietary kernel module
(nvidia binary driver), and got the following error trying to load it:

  nvidia: module license 'NVIDIA' taints kernel.
  nvidia: Unknown symbol print_tainted

It appears that this kernel build is incomplete.  This may be related to a GCC
optimization issue which appears to have been discovered and supposedly fixed
back in FC4 (bug 149758)

Version-Release number of selected component (if applicable):

  kernel-2.6.15-1.2054_FC5

How reproducible:

  Always

Steps to Reproduce:
1.  Install 2054 build kernel
2.  Attempt to load module which references 'print_tainted'
3.
  
Actual results:

  Unknown symbol print_tainted

Expected results:

  Successful module load

Additional info:
Comment 1 Alex Stewart 2006-03-18 13:37:39 EST
Sorry, the bug I probably should have referenced which identifies the actual
problem is bug 150150
Comment 2 Dave Jones 2006-03-19 19:27:57 EST

*** This bug has been marked as a duplicate of 185384 ***

Note You need to log in before you can comment on or make changes to this bug.