Bug 1858772 - Fix TestPodAffinityConfiguration flake
Summary: Fix TestPodAffinityConfiguration flake
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks: 1858927
TreeView+ depends on / blocked
 
Reported: 2020-07-20 11:17 UTC by Oleg Bulatov
Modified: 2020-10-27 16:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 580 0 None closed Bug 1858772: Fix TestPodAffinityConfiguration flake 2020-09-14 04:38:22 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:31 UTC

Description Oleg Bulatov 2020-07-20 11:17:42 UTC
Description of problem:

The e2e test TestPodAffinityConfiguration is flaky because it doesn't wait until the operator become available.

Version-Release number of selected component (if applicable):

4.5

How reproducible:

Sometimes

Steps to Reproduce:
1. Creata a pull request for openshift/cluster-image-registry-operator

Actual results:

Sometimes tests become red even if nothing was changed

Expected results:

Tests don't flake

Additional info:

This is only about CI.

Comment 5 errata-xmlrpc 2020-10-27 16:16:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.