Bug 1858927 - Fix TestPodAffinityConfiguration flake
Summary: Fix TestPodAffinityConfiguration flake
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.z
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1858772
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-20 19:06 UTC by OpenShift BugZilla Robot
Modified: 2020-09-21 17:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 581 None closed [release-4.5] Bug 1858927: Fix TestPodAffinityConfiguration flake 2020-09-16 14:20:20 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:21 UTC

Description OpenShift BugZilla Robot 2020-07-20 19:06:19 UTC
+++ This bug was initially created as a clone of Bug #1858772 +++

Description of problem:

The e2e test TestPodAffinityConfiguration is flaky because it doesn't wait until the operator become available.

Version-Release number of selected component (if applicable):

4.5

How reproducible:

Sometimes

Steps to Reproduce:
1. Creata a pull request for openshift/cluster-image-registry-operator

Actual results:

Sometimes tests become red even if nothing was changed

Expected results:

Tests don't flake

Additional info:

This is only about CI.

Comment 1 Oleg Bulatov 2020-07-31 15:28:57 UTC
Depends on bug 1858772.

Comment 7 errata-xmlrpc 2020-09-21 17:42:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.