Bug 185909 - Please rebuild the package
Summary: Please rebuild the package
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL: http://www.fedoraproject.org/wiki/Ext...
Whiteboard:
Keywords:
: 188721 (view as bug list)
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2006-03-20 00:13 UTC by Enrico Scholz
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 19:25:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rrdtool 1.0.50 specfile patch (2.46 KB, patch)
2006-06-04 22:10 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Enrico Scholz 2006-03-20 00:13:40 UTC
Moving to Fedora Core 5 requires to rebuild all arch specific Fedora
Extras packages. Accordingly build dates, this does not seem to have
happened for this package.

Please rebuild the package as soon as possible. When you did this
already, ignore and close this bugreport please.

For more information see
      http://www.fedoraproject.org/wiki/Extras/FC5Status.

Comment 1 Nick Sharp 2006-04-10 21:11:47 UTC
I use rrdtool and would like to be able to install a recent version with yum
from extras rather than having to compile it myself. It seems to me (relative
newbie, so forgive if I have missed something) that the current version offered is:
rrdtool - 1.0.49-5.fc4.I386
I believe 1.0.49 is about 20 months old?
I would hope to look forward soon to 'yum install rrdtool' offering:
rrdtool - 1.2.12.fc5.I386
I note that rrdtool shows on add/remove when you choose LIST but I cannot find
it anywhere in the BROWSE sets.  Did I miss it?  If not, should it be there?
Many thanks
Nick Sharp

Comment 2 Matthias Saou 2006-04-12 15:58:47 UTC
*** Bug 188721 has been marked as a duplicate of this bug. ***

Comment 3 Jose Pedro Oliveira 2006-04-12 16:22:03 UTC
Pasting the following info from #188721:

A couple of perl related things that could also be corrected:

* remove the empty .../i386-linux-thread-multi/auto/RRDs/RRDs.bs file
* change the perl modules man pages into section 3 
  /usr/share/man/man1/{RRDp.1.gz,RRDs.1.gz}
* maybe use the configure PERL_MAKE_OPTIONS variable (?)

/jpo

Comment 4 Davide Rossetti 2006-04-18 09:31:20 UTC
additional bug of rrdtool-1.0.49-5.fc4 on x86_64 FC5 and FC4 as well.

on x86_64 FC5:
ldd /usr/lib64/librrd.so
        libz.so.1 => /usr/lib64/libz.so.1 (0x0000003c97500000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003c97100000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003c96e00000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)

it is missing the dependency on libpng[12], which is present in the FC5 i386 rpm:
ldd /usr/lib/librrd.so
        linux-gate.so.1 =>  (0x00c6b000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00515000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00d3c000)
        libm.so.6 => /lib/libm.so.6 (0x00d15000)
        libc.so.6 => /lib/libc.so.6 (0x00111000)
        /lib/ld-linux.so.2 (0x00bc6000)

davide


Comment 5 mreymann 2006-05-10 09:17:55 UTC
Consequently, php-rrdtool-1.0.49-5.fc4.i386 on FC5 produces a PHP CLI error:

[pigpen@mybox ~]$ php -v
PHP Warning: PHP Startup: ,<G: Unable to initialize module
Module compiled with module API=20041030, debug=0, thread-safety=0
PHP compiled with module API=20050922, debug=0, thread-safety=0
These options need to match
in Unknown on line 0
PHP 5.1.2 (cli) (built: Feb 28 2006 06:21:15)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
with eAccelerator v0.9.5-cvs200603090012-dev, Copyright (c) 2004-2006
eAccelerator, by eAccelerator

Comment 6 Jarod Wilson 2006-06-01 19:47:11 UTC
Bump. I see 1.1.12 in rawhide, but we need a functional FC5 version too. Not
sure if 1.1.12 (or 1.1.13, which is out now) should get pushed for FC5, or if we
should just respin 1.0.49 (or 1.0.50, which is also out now) for FC5... If there
are no objections, I can just respin an FC5 1.0.50...

Comment 7 Jarod Wilson 2006-06-02 19:52:20 UTC
To get the ball rolling, I simply did a rebuild of 1.0.49, since 1.0.50 proved
to be a royal pain in the ass. However, I've just completed the necessary
changes to get 1.0.50 building properly as well. Haven't heard any objections
and in fact got a few endorsements, so I'm going to go ahead and submit the
1.0.50 build.

Comment 8 Jose Pedro Oliveira 2006-06-04 22:10:24 UTC
Created attachment 130465 [details]
rrdtool 1.0.50 specfile patch

Jarod,

The patch corrects several more problems:
 * adds the missing post/postun scripts (ldconfig)
 * adds the perl(:MODULE_COMPAT_xxx) requirement to main rrdtool RPM
   (as it installs perl modules in perl owned directories)
 * changes the subpackages requirements from "Requires: %{name} = %{version}"
to
   "Requires: %{name} = %{version}-%{release}"
 * removes the CVS files (in the %prep section)
 * removes an empty .bs file (perl related)

jpo

Comment 9 Jarod Wilson 2006-06-05 19:24:10 UTC
Just merged all changes to both FC5 and devel branches, new builds coming soon...

Comment 10 Matthias Saou 2006-06-06 09:54:56 UTC
Great, thanks a lot. Jarod : Do you want to take over rrdtool maintainership?

Comment 11 Jarod Wilson 2006-06-06 13:11:56 UTC
(In reply to comment #10)
> Great, thanks a lot. Jarod : Do you want to take over rrdtool maintainership?

Sure, I'd be happy to.


Note You need to log in before you can comment on or make changes to this bug.