Bug 1859196 - etcd: Fix deadlock bug in mvcc
Summary: etcd: Fix deadlock bug in mvcc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks: 1859201
TreeView+ depends on / blocked
 
Reported: 2020-07-21 12:21 UTC by Sam Batschelet
Modified: 2020-10-27 16:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1859201 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:46 UTC

Description Sam Batschelet 2020-07-21 12:21:46 UTC
Description of problem: In the case where a slow or new member receives a snapshot from leader and attempts to applySnapshot meanwhile cluster runs compaction a deadlock can occur.


Version-Release number of selected component (if applicable): etcd 3.x


How reproducible: conditions would need to exist which would be relatively low probability. But the result would be very hard for an already struggling cluster to overcome.


Steps to Reproduce:
1.partition member
2.perform a lot of writes to cluster
3.unpartition member right before compaction

Actual results: cluster can experience deadlock and hang causing possible disruption.


Expected results: cluster remains available 


Additional info:

Comment 5 errata-xmlrpc 2020-10-27 16:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.