Bug 1859201 - etcd: Fix deadlock bug in mvcc
Summary: etcd: Fix deadlock bug in mvcc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1859196
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-21 12:26 UTC by Sam Batschelet
Modified: 2020-08-10 13:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1859196
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift etcd pull 54 None closed Bug 1859201: bump etcd v3.4.9 2020-09-13 14:38:19 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:39 UTC

Description Sam Batschelet 2020-07-21 12:26:02 UTC
+++ This bug was initially created as a clone of Bug #1859196 +++

Description of problem: In the case where a slow or new member receives a snapshot from leader and attempts to applySnapshot meanwhile cluster runs compaction a deadlock can occur.


Version-Release number of selected component (if applicable): etcd 3.x


How reproducible: conditions would need to exist which would be relatively low probability. But the result would be very hard for an already struggling cluster to overcome.


Steps to Reproduce:
1.partition member
2.perform a lot of writes to cluster
3.unpartition member right before compaction

Actual results: cluster can experience deadlock and hang causing possible disruption.


Expected results: cluster remains available 


Additional info:

Comment 3 ge liu 2020-07-29 10:08:23 UTC
Close this bug according to test result in jira issue: https://issues.redhat.com/browse/ETCD-105

Comment 5 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.