Bug 1859258 - Notification Drawer does not open on small/med size screen widths, prevents content from showing in Safari
Summary: Notification Drawer does not open on small/med size screen widths, prevents c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1867454 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-21 14:59 UTC by Joe Caiani
Modified: 2020-10-27 16:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Console loaded successfully in Safari (472.02 KB, image/png)
2020-08-21 09:05 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6252 0 None closed Bug 1859258: Pf package update with fix for nested drawers 2020-09-07 06:06:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:16:46 UTC

Description Joe Caiani 2020-07-21 14:59:50 UTC
Description of problem:
Notification Drawer does not open on small/med size screen widths. Only with screen widths 1800px and over will it open. 1800 pixels is the point at which we set the inline=true/false prop on the drawer component.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. set drawer width less than 1800px and note the notification drawer won't open
2.
3.

Actual results:


Expected results:


Additional info:

This may also cause an issue displaying the console app while using safari.

Comment 1 Joe Caiani 2020-07-21 15:00:51 UTC
An issue is being worked on in pf core to fix this upstream here:

https://github.com/patternfly/patternfly/issues/3260

Comment 2 Joe Caiani 2020-07-31 20:32:22 UTC
fixed in pf core here: https://github.com/patternfly/patternfly/pull/3328
contribution from latest pf package should fix this.

Comment 3 Jakub Hadvig 2020-08-10 12:50:42 UTC
*** Bug 1867454 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2020-08-11 01:31:55 UTC
this is a recording https://recordit.co/lLUKgdN67l

Comment 5 Samuel Padgett 2020-08-19 15:14:29 UTC
This bug also caused the main content area to render as white in Safari, which is fixed: https://github.com/openshift/console/pull/6252#issuecomment-675027938. We should make sure to test Safari when verifying the bug.

Comment 9 Yadan Pei 2020-08-21 09:05:53 UTC
Created attachment 1712150 [details]
Console loaded successfully in Safari

set browser window size: 1079(width) x 712(height) and visit our console in Safari, pages can be loaded completely, notification drawer can be opened and closed.

Verified on Safari 13 with build 4.6.0-0.nightly-2020-08-20-204917

Comment 11 errata-xmlrpc 2020-10-27 16:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.