Bug 186009 - Installation of Errata RHBA-2006:0108-5 breaks 'ant'
Installation of Errata RHBA-2006:0108-5 breaks 'ant'
Status: CLOSED DUPLICATE of bug 186010
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ant (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Deepak Bhole
Depends On:
  Show dependency treegraph
Reported: 2006-03-20 18:15 EST by David Bennett
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-31 18:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Bennett 2006-03-20 18:15:01 EST
Description of problem:

After updating the java-1.4.2-ibm to release 1jpp_13rh,  the 
'ant' command breaks with the following error:

  The java class is not found:  org/apache/tools/ant/launch/Launcher

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. log in
2. run ant --execdebug

Actual results:

exec "/usr/bin/java" -classpath "/usr/bin/build-classpath: error: 
JVM_LIBDIR /usr/lib/jvm-exports/java-1.4.2-ibm- does not exist or is 
not a directory" -Dant.home="/usr/share/ant" -
Dant.library.dir="/usr/share/ant/lib" org.apache.tools.ant.launch.Launcher -
lib ""
The java class is not found:  org/apache/tools/ant/launch/Launcher

Additional info:

It appears that the directory:


Was replaced by:

Issuing the following commands fixes the problem:

  cd /usr/lib/jvm-exports
  ln -s java-1.4.2-ibm- java-1.4.2-ibm-
Comment 1 Deepak Bhole 2006-05-31 18:05:52 EDT

*** This bug has been marked as a duplicate of 186010 ***

Note You need to log in before you can comment on or make changes to this bug.