Bug 186032 - nv driver not working
nv driver not working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 186034 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 01:38 EST by Michael Cool
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 12:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file (2.72 KB, text/plain)
2006-03-24 08:24 EST, Peter Dawes
no flags Details
X server log (45.17 KB, text/plain)
2006-03-24 08:25 EST, Peter Dawes
no flags Details

  None (edit)
Description Michael Cool 2006-03-21 01:38:50 EST
Description of problem:
on certain Nvidia cards (mainly XFX cards), the screen will not be displayed 
properly, therefor anaconda is inusable (in my particular case, i get green 
stripes, and no image. the problem lies in the fact that Anaconda forces 
itself to use the 'nv' driver instead of 'vesa' (it would work with vesa)

Version-Release number of selected component (if applicable):


How reproducible:
Boot the FC5 install, with a XFX graphics card) and just run Anaconda

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
you should make an option where the user can choose what driver Anaconda will 
use
Comment 1 Chris Lumens 2006-03-21 09:47:35 EST
*** Bug 186034 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-03-21 11:44:14 EST
The driver package exports what PCI ids it supports.

Note that you can force anaconda to use vesa instead by booting with 'linux vesa'
Comment 3 Peter Dawes 2006-03-22 16:14:28 EST
I can confirm this with a Geforce 6800 GT.  The "nv" driver just corrupts the
screen.  The "vesa" driver works OK, but is very limited...  Note this happens
both during install, and afterwards.  As long as I set the driver to "vesa", I
can use the system.  If I try to use the "nv" driver (which is what it should
be), I get nothing but corrupt graphics, to the point of having to actually
reboot (just killing the X-server doesn't restore the video).  This is with FC5
x86_64, on an ASUS A8V Deluxe, AMD64 3800+, 1 GB RAM.  Works (worked) fine in
Fedora Core 3 and 4.  I'm normally using a dual-monitor setup (one LCD, one
CRT), but I've tried it with just the CRT attached as well.  
Comment 4 Mike A. Harris 2006-03-23 23:36:05 EST
Using the 'nv' driver, add the following option to the xorg.conf:

    Option "noaccel"

Restart the X server and report back the results.  Attach the X server log
file and config file from the new configuration as individual uncompressed
file attachments using the link below.
Comment 5 Peter Dawes 2006-03-24 08:22:46 EST
Noaccel option makes no difference.  Attaching config file and X server log from
the attempt.
Comment 6 Peter Dawes 2006-03-24 08:24:24 EST
Created attachment 126621 [details]
Config file
Comment 7 Peter Dawes 2006-03-24 08:25:32 EST
Created attachment 126622 [details]
X server log
Comment 8 Peter Dawes 2006-03-24 08:28:58 EST
I've been looking on the xorg and freedesktop sites - this bug may be related to
https://bugs.freedesktop.org/show_bug.cgi?id=6037  (in fact, it most likely is...)
which links to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=182396 .  I
don't know why I didn't find that one on my first look through bugzilla... 
might be a duplicate.
Comment 9 Mike A. Harris 2006-06-14 12:29:05 EDT
Our bugzilla database had a catastrophic failure on June 13, 2006
which lost all bug changes from Thurs June 9th through 13th.  I have
bugzilla email records of the time period however, and will be
restoring as many changes as I can manually.
Comment 10 Mike A. Harris 2006-06-14 12:29:36 EDT
Ok if "noaccel" does not work, try booting into runlevel 3, logging in as
root, and running "startx", or alternatively disable or uninstall rhgb
and reboot into X again.

Does the problem still occur in runlevel 3, or with rhgb out of the way?
rhgb is known to break otherwise working video setups, in the name of
eye candy, and we know it breaks various things on nvidia setups thus
far.

That may help narrow things down...


Comment 11 Mike A. Harris 2006-06-14 12:30:31 EDT
------- Additional Comments From peterd@uwo.ca  2006-06-10 12:10 EST -------
Nope, runlevel 3 "startx" (as root) doesn't help.
Comment 12 Mike A. Harris 2006-06-14 12:34:19 EDT
Alright, it appears that the "nv" driver does not properly support
this chip adequately enough.  We will track the issue in the upstream
bug report 6037 as referenced in comment #8.

When Nvidia has submitted patches to X.org which fix the problem, and
they've been committed to CVS, we'll review them for consideration in
a future 'nv' driver update.

Thanks for your testing.

Setting status to "UPSTREAM"

Note You need to log in before you can comment on or make changes to this bug.