Bug 186067 - fc4 to fc5 upgrade fails with 128M memory
fc4 to fc5 upgrade fails with 128M memory
Status: CLOSED DUPLICATE of bug 186090
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-03-21 09:21 EST by Mogens Kjaer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 09:46:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mogens Kjaer 2006-03-21 09:21:36 EST
Description of problem:

If I upgrade a machine with 128M from FC4 to FC5 it
will fail with a cannot allocate memory error.

I run the installer in text mode.

If I manually switch console at an early stage and do a

swapon /dev/hda2

the upgrade runs succesfully.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Take a machine with 128M RAM
2. Install FC4
3. Upgrade to FC5
  
Actual results:

Failure

Expected results:

The upgrade should succeed

Additional info:
Comment 1 Jeremy Katz 2006-03-21 11:49:31 EST
We used to do an early swap on for upgrades.  Somehow, we appear to have lost that 
Comment 2 David Cantrell 2006-03-21 11:55:12 EST
Yeah, I replaced that functionality with an automatic online order to Crucial
for 1024MB of memory for the user.  The installer *should* be pausing to wait
for that order, but I guess it isn't.  I'll look in to this and see what we can
do.  Might just have to enable swap again.
Comment 3 Peter Fales 2006-03-22 11:46:37 EST
Similar story here.   However, in my case anaconda *did* mount the existing swap
partition on /dev/hda5.  But it wasn't big enough (128M) and still hit an out of
memory condition midway through the install.

My workaround was to switch to the Alt-F2 console and manually create a 128M
swap file on /mnt/sysimage/tmp.   This provides a total of 256M of swap which is
apparently enough to allow the install to finish.   (I saw "free" report at
least 186M of swap used - not sure if that's the max)
Comment 4 Mogens Kjaer 2006-03-22 12:17:25 EST
I've tried upgrading another machine. This time it did in fact use the
swap partition automatically. In fact, a manual swapon makes the installation
fail.

The difference between the two upgrades is that the first (i.e.
where swap wasn't enabled) install was done from CD, and the second
via NFS.
Comment 5 John E. Harbold 2006-03-30 09:31:05 EST
I've tried several times to do a FTP upgrade to no avail.  After 12 hours, I get
insufficient disk space.  Could it be I don't have enough swap space.  I
currently have over 600 MB worth.  Does anaconda need more?
Comment 6 David Cantrell 2006-03-30 13:11:40 EST
OK, I've refreshed my iMac here with FC4 and started an FC5 upgrade from CD. 
The install has been running for hours now and all but 1.5MB of physical is
reported as in-use as well as 138MB of swap.  The install is at 33% complete and
is still running, but the disk is really busy.

This iMac has 128M of physical memory.  I think that 128M is just not enough for
a speedy install, but it will *probably* work.

We bumped the minimum amount of RAM required for a GUI installation, so with
128M of memory your only option now is the text mode install.  If you have more
than 140000k of available memory, anaconda will not enable swap during
installation.  I'm thinking this limited should be increased because 128M of
physical RAM and 128M of swap isn't enough.  It's using right at our early swap
requirement, so I'm thinking it should be bumped.

I'll post again once this install finished or crashes.
Comment 7 Fdor 2006-04-01 10:57:09 EST
I had same problem: my upgrade from FC4 to FC5 (with CDs and 256M RAM) froze
while preparing transaction to install.

In Bug 186090 a guy tells he has same problem, and has taken a screenshot:

  https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=126404

I've fixed my problem by following the suggestion of comment #1 (just enabling
my swap partition):

1. Just before clicking OK to begin the preparation of the transsacction,
   change to text mode:

   control+alt+F2.

2. See the number of the swap partition:

   # parted /dev/hda print | grep swap
   4       157GB   158GB   946MB   primaria  linux-swap

3. Enable the swap partition:

   # swapon /dev/hda4

4. Go back to graphical mode:

   alt+F7

5. Click OK to install.


Is there any way to explain this steps to people upgrading to FC5? Perhaps a
warning in the download page and mirrors?
Comment 8 Callum Lerwick 2006-04-02 14:20:49 EDT
I've wasted an entire day on this problem. Took me a while to figure out what's
going on. Fresh install with x86_64 on 256mb RAM, booted from USB stick with the
DVD iso on a second hard drive.

It locks up right at the package install screen, even before the "Preparing
transaction" dialog comes up. Every time. If I quickly switch over to the text
console before this happens, I can see that the OOM killer has kicked in. Once
it killed the X server then mini-wm, and another time it killed anaconda then
the X server.

I tried setting up a swap partition, but it seems it doesn't actually do the
partitioning until after the lockup point. So it doesn't help.

I'm trying again with a pre-existing swap.
Comment 9 Callum Lerwick 2006-04-02 15:38:30 EDT
Nope, pre-existing swap doesn't help. It doesn't enable it soon enough.

If I enable swap manually, I just get a dialog saying "Error enabling swap
device hda5: Device or resource busy" and "Press OK to reboot your system".

This is bogus. Completely totally bogus. I'm dead in the water.
Comment 10 John E. Harbold 2006-04-02 21:40:28 EDT
I was able to successfully upgrade to FC5.  There is no problem with anaconda. 
I just didn't have enough disk space for FC5 with my currents installed RPMS. 
By removing enough old and unnecessary RPMS I was able to successfully upgrade
to FC5. See my last comment in Bug 186541 for details.
Comment 11 David Cantrell 2006-04-03 09:46:44 EDT
I'm marking this as a dupe of bug 186090.  Please see the workarounds posted there.

*** This bug has been marked as a duplicate of 186090 ***

Note You need to log in before you can comment on or make changes to this bug.