Bug 186090 - Upgrade from FC4 to FC5 frozen during upgrade
Upgrade from FC4 to FC5 frozen during upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 186067 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 10:57 EST by Henri Ala-Peijari
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 19:34:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of frozen screen (610.54 KB, image/jpeg)
2006-03-21 10:57 EST, Henri Ala-Peijari
no flags Details

  None (edit)
Description Henri Ala-Peijari 2006-03-21 10:57:56 EST
Description of problem:
I was trying to upgrade a FC4 64bit system on an AMD 3000+ processor Asus A8N-E
motherboard radeon X550 and the upgrade froze on "Preparing transaction from
installation source"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Upgrade from FC4 64bit to FC5 64bit from DVD media (media checked ok)
2.Frozen (check photo for actual point of freezing)
3.
  
Actual results:
FC5 upgrade detects the system as an FC4.92 and subsequently upgrade install
frozen. I had another installation on the target drive, which was FC5test3 on
partition 3 and it also displayed as FC4.92.

Expected results:
Upgrade from FC4 64bit  to FC5 64bit

Additional info:
Comment 1 Henri Ala-Peijari 2006-03-21 10:57:56 EST
Created attachment 126404 [details]
Picture of frozen screen
Comment 2 Paul Nasrat 2006-03-21 11:10:16 EST
This stage can take some time, particularly on upgrades dependant on how many
packages you have installed - how long did you leave it.  Did you perform a
media check, were there any messages on tty3 and tty4 (ctrl-alt F3/F4).  How
much memory do you have?
Comment 3 Henri Ala-Peijari 2006-03-21 11:19:43 EST
It was frozen for over 15minutes and there was no response to mouse movement and
the blue thing going around was also frozen. No response to ping from another
machine. I have 512megs DDR400 memory. I burnt the media with K3B with verify
and tested the media with Fedora's mediacheck before install. 
Comment 4 Paul Nasrat 2006-03-21 11:25:06 EST
Please try and reproduce again, trying one of these at a time.

When it freezes see if you can switch to tty3 and look for messages.

Prior to this stage at the confirmation screen switch to tty2 and swapon, then
switch to tty7 and hit continue.
Comment 5 Henri Ala-Peijari 2006-03-21 11:30:28 EST
Should I erase the installation, install FC4 and then upgrade to FC5 or can I
try to upgrade the failed installation again?
Comment 6 Paul Nasrat 2006-03-21 11:35:23 EST
At this stage we shouldn't have written to disk anything so you should just be
able to boot back into FC4 - just check you can do that, and then just boot the
installer again.  Else yes if it's in a state where we've upgraded partially a
clean reproducer is better (FC4, yum update, retry upgrade).

Comment 7 Henri Ala-Peijari 2006-03-21 18:03:44 EST
I had to try a clean install with FC4. I couldn't yum the updates. First,
conflict with some kernels and when I ran it with "yum -y
--exclude=gnbd-kernel,dlm-kernel,GFS-kernel,cman-kernel update" it ran till
update  which was named file or files and was number 111 (out of thousands) and
stalled (CPU 100% idle) [This was in running transaction mode]. I killed it and
tried again, now I get Error: kernel conflicts with udev < 071-0.FC4.2 and I
have no idea on how to bypass this, so I guess I'll just fresh install FC5. 

Curious that upgrading is such a pain but when the system is running it stays on
for months without any errors.
Comment 8 Paul Nasrat 2006-03-21 18:09:59 EST
Was this an everything install? 
Comment 9 Henri Ala-Peijari 2006-03-21 19:02:44 EST
Yes, I've usually found that it's easier to install everything rather than find
out at some point when entering a command for a program that I didn't choose to
install it.
Comment 10 Paul Nasrat 2006-03-21 19:34:57 EST
If it's an everything install it'll take a while to process the transaction, you
just didn't leave it long enough I think.

As for comment #7 just remove all the GFS stuff, they can get out of sync (you
did ask for everything).  Then yum update.

It will take a long time but I've successfully done a number of FC4 everything
upgrades.

It'll be quicker to do a clean install though.
Comment 11 Fdor 2006-04-01 10:59:13 EST
Probably related to Bug 186067
Comment 12 Callum Lerwick 2006-04-02 14:22:58 EDT
Yeah, this is a dupe of 186067
Comment 13 David Cantrell 2006-04-03 09:47:18 EDT
*** Bug 186067 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.