Bug 186074 - Via Epia freezes after a few hours of operation
Via Epia freezes after a few hours of operation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 09:59 EST by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2006-03-21 09:59:17 EST
+++ This bug was initially created as a clone of Bug #145185 +++

Description of problem:
I had a fresh installation of FC3 on a Via EPIA 800 board (having a
Via C3 CPU). After a random amount of time (usually after about 10 to
100 minutes), the system would freeze without printing any error message.


Version-Release number of selected component (if applicable):
cpuspeed v1.1b

How reproducible:
Always

Steps to Reproduce:
1. Just wait. It will freeze after some time. 
2.
3.
    

Actual Results:  Total freeze (no kernel panic message). A hard reset
is required

Additional info:

It actually easy (but not obvious) to fix this. If cpuspeed is shut
down (or if the cpuspeed service is deactivated with chkconfig) the
system runs fine.

See also discussion thread
http://www.fedoraforum.org/forum/showthread.php?t=31879


greetings, Rolf

-- Additional comment from davej@redhat.com on 2005-01-14 23:08 EST --


*** This bug has been marked as a duplicate of 143424 ***

-- Additional comment from bugzilla@redhat.com on 2006-02-21 14:07 EST --
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

+++ Clone end +++

It happen here on systems now after RHEL4U3 update:
kernel-2.6.9-34.EL
kernel-utils-2.4-13.1.80

# cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 8
cpu MHz         : 1002.482
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr cx8 mtrr pge cmov pat mmx fxsr sse rngn
bogomips        : 2007.06
Comment 1 Dave Jones 2006-03-27 17:16:55 EST
the longhaul module (CONFIG_X86_LONGHAUL) should never have been built for
RHEL4, as it's known broken, and requires a huge amount of effort to make it
work reliably.

I recommend disabling that in a future RHEL4 update.
In the meantime, you should be able to safely just rm -f the longhaul.ko file(s)
from /lib/modules/...
Comment 2 Jason Baron 2006-03-27 17:31:04 EST
hmmm...we actually have this built in so you can't just remove the module :(
There is a 'dont_scale_voltage' module option, but i have no idea if this will
help...there is also a debug flag that can be set.
Comment 3 Dave Jones 2006-03-28 19:26:52 EST
the option is worthless (the voltage scaling isn't present iirc) the whole
driver is unfixable without major kernel-wide changes to ensure no DMA happens
to any device around a speed-change transaction.
Comment 4 Brian Maly 2006-09-12 15:02:35 EDT
This appears to be a duplicate of Bug 172730
Comment 6 RHEL Product and Program Management 2006-10-11 11:16:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jay Turner 2006-10-17 10:19:25 EDT
QE ack for 4.5.
Comment 8 Jason Baron 2006-12-14 21:32:37 EST
committed in stream U5 build 42.32. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 10 Mike Gahagan 2007-04-03 17:22:02 EDT
Longhaul support has been removed from the -52 kernel.
Comment 12 Red Hat Bugzilla 2007-05-07 20:49:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.