Bug 186079 - Anaconda crash: "no disk space" ... _isys.umount -> SystemError: (16, 'Device or resource busy')
Anaconda crash: "no disk space" ... _isys.umount -> SystemError: (16, 'Device...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 10:15 EST by Jesse Glick
Modified: 2008-06-16 21:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file, bzipped (409.34 KB, application/octet-stream)
2006-03-21 10:15 EST, Jesse Glick
no flags Details
bzipped anaconda dump file (27.71 KB, application/x-tar)
2006-03-24 00:41 EST, Chad Paavola
no flags Details
snake dump (85.27 KB, text/plain)
2008-03-10 21:05 EDT, Dale E. Moore
no flags Details
df -h (488 bytes, text/plain)
2008-03-10 21:06 EDT, Dale E. Moore
no flags Details
fdisk -l (593 bytes, text/plain)
2008-03-10 21:06 EDT, Dale E. Moore
no flags Details
free (236 bytes, text/plain)
2008-03-10 21:06 EDT, Dale E. Moore
no flags Details
mount (695 bytes, text/plain)
2008-03-10 21:07 EDT, Dale E. Moore
no flags Details
uname -a (95 bytes, text/plain)
2008-03-10 21:07 EDT, Dale E. Moore
no flags Details

  None (edit)
Description Jesse Glick 2006-03-21 10:15:44 EST
Description of problem:

I was running the FC5 DVD to upgrade an FC4 installation, on a Toshiba Tecra M2
w/ 1Gb RAM. FC4 was on /dev/hda6, a 10Gb ext3 partition with about 3.6Gb free at
the time. Configuration stage went smoothly; but a minute or so after I gave the
go-ahead to install, it displayed a dialog saying something to the effect of
"there is insufficient disk space to copy the image to disk". I thought this was
odd, since I had several gigs free, but clicked OK. Then an exception dialog
appeared. I will attach the Anaconda log (big, sorry).


Version-Release number of selected component (if applicable):

FC-5-i386-DVD.iso

How reproducible:

Not sure yet.

Additional info:

1. I do have an NTFS partition currently, and I have seen bug #185853, so I will
try disabling that and see if it helps.

2. My first install attempt failed for a different reason, in case this is
relevant: on the screen prompting to upgrade FC4, after clicking Next I received
an error saying that >1 partition had label "/" and the installation could not
continue. I had to reboot. In fact /dev/hda2 contained an ext3 partition on
which I had tried (unsuccessfully...) to install Ubuntu some time ago, so it
probably had a "/" label. As a quick fix I used parted to make this space into a
fat32 partition. After restarting the FC5 installer it seemed to go past this
stage OK, so I assume my action worked.
Comment 1 Jesse Glick 2006-03-21 10:15:44 EST
Created attachment 126402 [details]
Anaconda dump file, bzipped
Comment 2 Jesse Glick 2006-03-21 12:53:54 EST
After (1) freeing up more disk space (about 5Gb free), (2) commenting out the
NTFS and VFAT partitions in /etc/fstab, and trying again, it worked.
Comment 3 Chad Paavola 2006-03-23 14:32:57 EST
I am having the same problem.  I am attempting to upgrade from FC4 to FC5.  The
FC4 install went flawlessly.  My hardware is a Shuttle AN35 motherboard with 512
MB ram.  I have two hard drives with a 10 GB "/" partition and a ~210 GB raid
partition md0 mounted on "/home".  The other partitions are swap and vfat.

My "/" partition has about 6.7 GB free.  Anaconda gave me the message "An error
occurred transferring the install image to your hard drive.  You are probably
out of disk space."  This error came right away, there didn't seem to be enough
time to fill up 6.7 gigs.  I also had the message "SystemError: (16, 'Device or
resource busy')" in my dump.

Perhaps it's coincidence, but I also had a disk related error when I tried a
fresh install.  In that case, anaconda said something like "problem unmounting
the CD."

I'll try getting rid of the vfat partition when I get home tonight.
Comment 4 Chad Paavola 2006-03-24 00:41:03 EST
Created attachment 126604 [details]
bzipped anaconda dump file

Commenting out the vfat partition had no effect.  I notice the problem seems to
be with umount, like in my broken clean install.
Comment 5 Chris Lumens 2006-03-24 10:46:37 EST
That error dialog is pretty terrible, since it'll pop up on any error when
reading  the stage2.img.  In this case, I see that you both have an error along
these lines in your dump files:

<4>hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
<4>hdc: media error (bad sector): error=0x34 { AbortedCommand LastFailedSense=0x03 }
<4>ide: failed opcode was: unknown
<4>end_request: I/O error, dev hdc, sector 105656

So it's possible this is a bad CD but our error reporting is just leading you on
the wrong track.  Are either machines still available for testing an upgrade? 
I'd like to see when this error message occurs if you actually are out of space
or not.
Comment 6 Jesse Glick 2006-03-24 11:39:51 EST
I have already upgraded to FC5 as mentioned so unfortunately I cannot retest the
installer.

I did do a check on the DVD before installing and it passed the verification check.
Comment 7 Chad Paavola 2006-03-24 11:59:23 EST
My machine is still available for testing.  I'm back to FC4.  I'd be happy to
run whatever test you think would be most useful.  My DVD passed the media check
as well but I could download and burn again or try the CDs.  Or I could
repartition my drives if you think that's necessary.  I was off a little on the
free space in my initial report, df -h gives:

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1             9.5G  3.0G  6.1G  33% /
/dev/shm              252M     0  252M   0% /dev/shm
/dev/md0              207G   57G  140G  29% /home

The vfat partition is still commented out of /etc/fstab
Comment 9 Dale E. Moore 2008-03-10 21:05:47 EDT
Created attachment 297548 [details]
snake dump
Comment 10 Dale E. Moore 2008-03-10 21:06:16 EDT
Created attachment 297549 [details]
df -h
Comment 11 Dale E. Moore 2008-03-10 21:06:31 EDT
Created attachment 297550 [details]
fdisk -l
Comment 12 Dale E. Moore 2008-03-10 21:06:45 EDT
Created attachment 297551 [details]
free
Comment 13 Dale E. Moore 2008-03-10 21:07:10 EDT
Created attachment 297552 [details]
mount
Comment 14 Dale E. Moore 2008-03-10 21:07:24 EDT
Created attachment 297553 [details]
uname -a
Comment 15 Dale E. Moore 2008-03-10 21:09:02 EDT
My FC5 to F7 upgrade gets this error even though I've tried all the options
mentioned here. I've attached several files to describe my system and will wait
on upgrading this system until I hear from you; hoping to help you resolve this
issue.
Comment 16 Dale E. Moore 2008-03-12 10:15:27 EDT
I'm thinking about following the instructions here
http://fedoraproject.org/wiki/YumUpgradeFaq to upgrade from FC5 to a more recent
Fedora version. Is there anything I can do to capture information for you about
this problem before I begin this alternative upgrade strategy?
Comment 17 Dale E. Moore 2008-03-14 11:39:19 EDT
Well folks, I'm sorry that my hunger to upgrade has pushed me to use
http://fedoraproject.org/wiki/YumUpgradeFaq and I can no longer help with this bug.

Sorry!
Dale E. Moore
Comment 18 Chris Lumens 2008-03-28 16:15:50 EDT
The exception logs here from all three reporters have messages indicating read
errors from the media.  If everyone ran media check and verified the state of
their media, then I am going to place blame on the kernel.
Comment 19 Bug Zapper 2008-05-14 07:59:56 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2008-06-16 21:12:00 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.