Bug 185853 - (anacondafc5ntfs) anaconda crash if ntfs exists in /etc/fstab
anaconda crash if ntfs exists in /etc/fstab
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 187281 187321 187626 188500 189848 190051 191067 191256 206408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-19 15:32 EST by Łukasz Trąbiński
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 11:34:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Łukasz Trąbiński 2006-03-19 15:32:01 EST
Description of problem:

At beginning instalation of FC5 from DVD-ROM anaconda crash if in /etc/fstab
exists line with ntfs filesystem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. put to /etc/fstab file line like this:
/dev/hdaXX               /windows                auto    umask=0022,rw   1 1
where /dev/hdaXX is ntfs filesystem

2. Try install FC5

3.
  
Actual results:

anaconda crash


Expected results:

ignore ntfs or unknow filesystems from /etc/fstab?

Additional info:
Comment 1 Chris Lumens 2006-03-20 16:36:31 EST
What message are you seeing from anaconda?
Comment 2 Łukasz Trąbiński 2006-03-20 16:47:21 EST
I don't precisely remember, message was in debug options, it was some error
about mounting
/dev/hda4               /windows                auto    umask=0022,rw   1 1
from /etc/fstab. It was of course during upgrade from FC4 to FC5, not install
new system.
Comment 3 Jeremy Katz 2006-03-21 11:34:06 EST
Unfortunately, if you use auto, there is no way to determine what filesystem
type you _really_ want.  We do ignore filesystems that are explicitly listed as
'ntfs', thus if you want it ignored on upgrade, use that instead of 'auto'
Comment 4 Chris Lumens 2006-03-29 14:01:48 EST
*** Bug 187281 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2006-03-30 09:29:09 EST
*** Bug 187321 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2006-03-30 20:47:38 EST
I initiated a bug report marked as duplicate. My fstab did not contain
references to ntfs partitions (per se or auto) I eliminated step by step other
file systems, vfat, smbfs, nfs etc. to no avail. Finally I removed fd0 the
floppy and got past the crash. It is quite possible that the problem lies in
ntfs but it appears that upgrades involving a number of file systems are a
problem. I can provide the original fstab and the minimal file needed to upgrade
or the diff file. 
Comment 7 Chris Lumens 2006-03-31 10:53:36 EST
Charles - on closer inspection, you're getting the exact same problem but in a
different way.  Your /dev/fd0 mount is an auto fstype as well, so that exploded.
 We need to be handling these better in general.
Comment 8 Chris Lumens 2006-04-03 15:05:47 EDT
*** Bug 187626 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2006-04-10 13:43:58 EDT
*** Bug 188500 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2006-04-25 09:45:15 EDT
*** Bug 189848 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2006-04-27 10:00:53 EDT
*** Bug 190051 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2006-05-08 14:00:50 EDT
*** Bug 191067 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2006-05-10 09:36:02 EDT
*** Bug 191256 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2006-09-14 09:47:42 EDT
*** Bug 206408 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.