Bug 1860936 - VM and VM template cannot have the same name when using URL source
Summary: VM and VM template cannot have the same name when using URL source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-27 13:53 UTC by Guohua Ouyang
Modified: 2020-10-27 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: datavolume name was hardcoded Consequence: all datavolumes created had the same name Fix: adding auto generated unique strings to datavolume name Result: any new datavolume will have unique name
Clone Of:
Environment:
Last Closed: 2020-10-27 16:17:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:20:30 UTC

Description Guohua Ouyang 2020-07-27 13:53:14 UTC
Description of problem:
1. Create a vm template 'testurl' with provision source url and then create vm 'testurl' with provision source url, it failed to start the vm.

2. Create a vm with 'testurl' with provision source url and then create a vm template 'testurl' with provision source url, the vm template cannot be created.

Error looks like below:
Error "Destination PVC already exists" for field "DataVolume.Name".

Version-Release number of selected component (if applicable):
4.5.3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-07-28 05:29:14 UTC
should be fixed by:
https://github.com/openshift/console/pull/5618

BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=1840766

Moving to modified instead of closing as duplicate because IIUC this should already be fixed by 1840766 at the time this one was opened ... and I would like to verify it's realy fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:17:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 6 errata-xmlrpc 2020-10-27 16:20:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.