Bug 186127 - when I try to rebuild the source rpm with xine enabled, i am getting /var/tmp/rpm-tmp.26718: line 61: --with-xine: command not found
when I try to rebuild the source rpm with xine enabled, i am getting /var/tm...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 14:51 EST by yonas abraham
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-01 04:15:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description yonas abraham 2006-03-21 14:51:40 EST
Description of problem:
when I try to rebuild the source rpm with xine enabled, i am getting 
/var/tmp/rpm-tmp.26718: line 61: --with-xine: command not found

Version-Release number of selected component (if applicable):
amarok-1.4-0.7.beta1_FC5


How reproducible:
install the amarok-1.4-0.7.beta1_FC5.src.rpm, edit amarok.spec and enable
use_nonefree. download xine-lib-devel from rpm.livna.org. run rpmrebuild -bb
amarok.spec. It seems to configure fine, but it exits with error msg as follows:
 ==========================
 =
 = The following extra functionality will NOT be included:
 =   - NMM-engine
 =   - MAS-engine
 =   - Helix-engine
 =   - MySql Support
 =   - Postgresql Support
 =   - MP4/AAC Tag Write Support
 =   - Moodbar Support
 =   - iPod Support
 =
 = The following extra functionality will be included:
 =   + aRts-engine
 =   + aKode-engine
 =   + GStreamer-engine
 =   + GStreamer-engine 0.10
 =   + xine-engine
 =   + libvisual Support
 =   + XMMS Visualization Wrapper
 =   + Konqueror Sidebar
 =   + MusicBrainz Support
 =   + iRiver iFP Support
 =
 ===============================================================================
Good - your configure finished. Start make now

+ --with-xine
/var/tmp/rpm-tmp.26718: line 61: --with-xine: command not found
error: Bad exit status from /var/tmp/rpm-tmp.26718 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.26718 (%build)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
error, see above

Expected results:
amarok and amarok-xine rpms

Additional info:
Comment 1 Aurelien Bompard 2006-03-22 03:00:53 EST
You should not need to edit the spec file, just use the following command to
rebuild it :
rpmbuild -bb --with nonfree amarok.spec
I just tried it and it worked fine.
Comment 2 yonas abraham 2006-03-22 10:04:12 EST
Good, the other reason I want to edit the spec file was to gent the
gstreamer-plugins-devel dependancy. in FC5, i can only get
gstreamer-plugins-base-devel-0.10.3-3.i386.rpm and
gstreamer-plugins-good-devel-0.10.2-1.i386.rpm vut no gstreamer-plugins-devel. 

It is saying gstreamer-plugins-devel >=0.8.4 is needed by amarok-1.4-0.7.beta1.i386
Comment 3 Michael Schwendt 2006-03-22 10:19:07 EST
No, it doesn't. Use:

rpmbuild -bb --define 'fedora 5' --with nonfree amarok.spec
Comment 4 yonas abraham 2006-03-22 13:57:15 EST
yes that was the trick. I successfully rebuild it.
Comment 5 Kyrre Ness Sjøbæk 2006-06-28 11:41:36 EDT
I'm just throwing in a short question - i'm trying to use amarok together with
gstreamer instead of Helix, as i can't get ALSA working on Helix. But it seems
to be disabled in the build (i use to use rythmbox, so gstreamer/alsa is working
just fine)... Is this correct, and i'll have to rebuild to get gstreamer
support, or is something wrong with my setup here?
Comment 6 Aurelien Bompard 2006-07-01 04:15:13 EDT
Upstream removed the gstreamer plugin from amarok 1.4 final, see bug 192802 for
more info. Since gstreamer is the only engine available on x86_64, I've brought
back the plugin from 1.4beta3, but I've only enabled it on plateforms where
Helix is not available.

So you could edit the spec file to have it built on every plateform, but it is
an unsupported version. Upstream said that in Amarok 1.4.1, which is in beta,
the gstreamer engine *may* be back.

Note You need to log in before you can comment on or make changes to this bug.