Bug 192802 - Update to amarok ver. 1.4.0 breaks gstreamer-10 audio-output
Update to amarok ver. 1.4.0 breaks gstreamer-10 audio-output
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
: 192831 192905 193037 193463 204745 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 04:11 EDT by Christian Nolte
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 07:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2006-05-23 04:11:34 EDT
Description of problem:
After the recent update of amarok to ver. 1.4.0 the only audio-output option
available is helix. gstreamer-10 is not recognized by amarok.

Version-Release number of selected component (if applicable):
Qt: 3.3.5
KDE: 3.5.2-0.2.fc5 Red Hat
amaroK: 1.4.0

gstreamer-plugins-bad-0.10.1-1.fc5
gstreamer-plugins-base-0.10.5-1
gstreamer-python-0.10.2-1.fc5
gstreamer-devel-0.10.4-1
gstreamer-plugins-good-0.10.2-1
gstreamer-plugins-ugly-0.10.2-1.lvn5
gstreamer-0.10.4-1
gstreamer-tools-0.10.4-1
gstreamer-plugins-base-devel-0.10.5-1

How reproducible:
Everytime

Steps to Reproduce:
1.Upgrade amarok to ver. 1.4.0
2.Start amarok
  
Actual results:

Before amarok is started, a message box appears that it needs RealPlayer for
proper helix-support and that the audio-output options should be reconfigured.
The next message box (which only appears one time at the first start-up after
the upgrade) indicates a problem with the gstreamer-10 plugin. In the
audio-output options helix is the only available plugin.

Expected results:

amarok should work with gstreamer-10.

Additional info:
-
Comment 1 Aurelien Bompard 2006-05-23 07:57:44 EDT
Gstreamer was disabled in Amarok 1.4 final by the Amarok devs, see line 25 in
/usr/share/doc/amarok-1.4.0/ChangeLog
Comment 2 Aurelien Bompard 2006-05-23 10:47:55 EDT
*** Bug 192831 has been marked as a duplicate of this bug. ***
Comment 3 Aurelien Bompard 2006-05-23 18:49:06 EDT
*** Bug 192905 has been marked as a duplicate of this bug. ***
Comment 4 Christian Nolte 2006-05-24 04:08:53 EDT
> Gstreamer was disabled in Amarok 1.4 final by the Amarok devs, see line 25 in
> /usr/share/doc/amarok-1.4.0/ChangeLog

If gst-10 has been disabled and the only available engine is helix, then there
should be a dependency on HelixPlayer in the SPEC-file. If one upgrades to the
current version and has HelixPlayer not installed it breaks amaroks audio-output.
Comment 5 Aurelien Bompard 2006-05-24 06:34:57 EDT
That's right, I've fixed this, update pending (-5.fdr5)
Comment 6 Aurelien Bompard 2006-05-24 18:32:16 EDT
*** Bug 193037 has been marked as a duplicate of this bug. ***
Comment 7 Aurelien Bompard 2006-06-23 02:20:21 EDT
*** Bug 193463 has been marked as a duplicate of this bug. ***
Comment 8 Kim Bisgaard 2006-07-14 05:25:32 EDT
Then there is no reason to build this package for eg. x86_64, where there is no
helix either!
Comment 9 Alex Lancaster 2006-08-31 08:31:22 EDT
There has been a regression, gstreamer support has disappeared again.  Since I
can't reopen this bug, I've opened a new one: bug #204745.

Also, why was this closed as NOTABUG?  If it was broken and then was fixed, it
was a bug and it should have been closed as CURRENTRELEASE or NEXTRELEASE?
Comment 10 Aurelien Bompard 2006-08-31 10:38:43 EDT
What I fixed was the dependency on HelixPlayer, which was not the subject of
this bug. Thus the NOTABUG.
Comment 11 Aurelien Bompard 2006-08-31 10:41:49 EDT
*** Bug 204745 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.