Bug 186189 - FC5 issues relating to kernel like arguements init and Xorg freeze; init 1 fails; custom kernel freezes Xorg
FC5 issues relating to kernel like arguements init and Xorg freeze; init 1 fa...
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-03-21 22:09 EST by Steve
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-24 17:40:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve 2006-03-21 22:09:20 EST
Description of problem:
I have some strange issues that don't specifically fall under the kernel but are
kernel related.
1. kernel arguements: init 1 and init 3 fail with error: resulting in
"Attempting to kill init" and halted system
  a. this may not be solely the fault of the kernel, see 2.
2. Kernels other than that of the one shipped with FC5 final don't work -- i
havn't tried devel FC kernel.
for instance i had a custom FC4 kernel which worked well with FC4 and no longer
works with FC5. I've recompiled and changed my config 5 times i've even tried
compiling a kernel using the same config that shipped with FC5. Something is wrong
Computer will boot fine until rhgb ends and Xorg is supposed to load, then
computer will freeze. init 1 or init 3 also does not work with custom kernels.

Version-Release number of selected component (if applicable):
kernel.org kernel: 2.6.16,, 2.6.16-git2; FC5 included kernel:
2.6.15-1.2054_FC5. Other revelent software: Xorg7.0, gnome 2.14

How reproducible: always

Steps to Reproduce:
INIT issue (kernels: custom and FC5 default)
1. boot with kernel arguement: init 1 or init 3
2. watch errors come and result in system halt like "Attempting to kill init"
1. boot with custom kernel using compiled with FC5 config file or the 4 other
custom kernels i tried
2. watch computer begin booting entering rhgb
3. computer freezes when it attempts to load gnome after rhgb
  i removed rhgb from argument, i dont feel its necesarry, computer boots faster
anyway. however, the result is the same computer freezes when after processing
all services when it attempts to load Xorg.
  i have automatic logon enabled so its most probably failing at X load but i
suppose it could be failing at gnome
Actual results:
stated above

Expected results:
I should be able to boot with arguements init 1 and init 3 with and the computer
should not halt with errors.

Something is off with Xorg. My custom kernels should work and not freeze
computer when loading X. They worked great in FC4.

Additional info:
Is there some big kernel difference between kernel.org's kernels vs Fedora's?
Is my custom kernel Xorg failing a kernel issue or is it something to do with Xorg.
My real thought is FC kernels in the past were very closely based with those of
kernel.org's kernel's, is this still the same case for FC5?
However, FC5 has a custom Xorg 7, which is different than FC4's Xorg 6.8
so what can i do? keep trying with different kernel configs or wait for and see
if there's an Xorg patch that need to be written
Comment 1 Steve 2006-03-23 10:40:31 EST
i semi-resolved this
 .. very similar to bug 182196 and bug 174646
i did the work around and commented out load dri in xorg.conf
since my custom kernels don't load it because they don't properly support it i guess
.. so i suppose this issue is just trying to get dri support properly
functioning in the kernel
there are still issues somewhere
i can't install propietary ati drivers ... well it installs not completely i get
errrors, like xorg says "no module for fglrx"
here's dmesg errors:
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg,
GERMANY' taints kernel.
fglrx: Unknown symbol inter_module_unregister
fglrx: Unknown symbol inter_module_get_request
fglrx: Unknown symbol inter_module_put
fglrx: Unknown symbol inter_module_register

ill recompile more times
but again here is a weird issue, in FC4 my custom kernel's worked and fglrx
worked with them fine
now i got my custom kernel working with the modification to xorg.conf, but fglrx
isnt working properly with kernel and or xorg.
Comment 2 Dave Jones 2006-03-24 17:40:16 EST
the ati driver is trying to use symbols which aren't present any more.

Note You need to log in before you can comment on or make changes to this bug.