Bug 186190 - no sound with snd-hda-intel driver
no sound with snd-hda-intel driver
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 22:40 EST by Seth Doty
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 03:41:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Doty 2006-03-21 22:40:15 EST
Description of problem:  I have a fresh install of FC5 on my Dell M140 laptop. 
it seems that the driver is probed correctly, but i cannot get any sound to
happen.  I have checked the volume and it is all the way up.


Version-Release number of selected component (if applicable):  0.10.4 and 0.10.3


How reproducible: every time


Steps to Reproduce:
1. install FC5 with a snd-hda-intel card
2. login to gnome
3.  play a sound
  
Actual results:
no sound at all..although the gstreamer test does run without errors, and the
gnome-volume-control detects the soundcard and has the volume set at full for
master and PCM

Expected results:
should play a sound

Additional info:  I attempted to also install the rc3 of alsa libs from the alsa
website and i still have no sound.
Comment 1 Seth Doty 2006-03-22 23:55:22 EST
gstreamer versions are shown, the alsa versions are 1.0.11rc2  and rc3...i
wasn't sure where this bug lies as alsa does actually seem to be decting this
card correctly so i thought gstreamer initially.  not really sure which it as at
the moment
Comment 2 Martin Stransky 2006-03-24 04:26:58 EST
driver for hda was improved in the latest drivers (rc4), you can check it,
how-to is here: http://people.redhat.com/stransky/alsa/

btw. main part of ALSA is driver (its version is in /proc/asound/version) and
FC5 kernel has only 1.0.11rc2 driver...
Comment 3 Lars E. Pettersson 2006-03-24 08:33:53 EST
FYI

I followed the instructions in the how-to and updated the drivers with
alsa-driver-1.0.11rc4.FC5.tar.bz2, but when i was to update the alsa-lib, and
the alsa-utils packages I got the following messages:

package alsa-lib-1.0.11-3.rc2.2 (which is newer than 
alsa-lib-1.0.11-1.rc4.FC5.test) is already installed
package alsa-utils-1.0.11-3.rc2 (which is newer than
alsa-utils-1.0.11-1.rc4.FC5.test) is already installed

So i skipped that staged, and rebooted, and now my sound at least works again...

I use:
Linux version 2.6.16-1.2069_FC5 (bhcompile@hs20-bc1-4.build.redhat.com) (gcc
version 4.1.0 20060304 (Red Hat 4.1.0-3)) #1 SMP Tue Mar 21 17:13:02 EST 2006

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)

(the kernel from updates-testing)
Comment 4 Martin Stransky 2006-03-27 08:07:28 EST
alsa-lib/utils aren't so important...
Comment 5 Seth Doty 2006-03-27 08:29:09 EST
sorry about the slow response, i've been away for a while.  the fact that the
system did find the card, and seem to put in the correct driver made me do the
alsa-lib package first, hoping it was just somthing weird.  anyway, i've
installed the alsa-driver package, and it seems to fix things every time.  after
a reboot things work the way they should on the 3 systems that i have played
with so far. of course this does also say that on 3 systems with intel cards,
and audigy's the problem occured..seems to be a recurring event in FC5 so far  
Comment 6 Martin Stransky 2006-03-28 03:41:57 EST
okay, closing as upstream.
Comment 7 Danny D'Amours 2006-03-30 15:36:13 EST
When is this scheduled to show up on updates-testing?
Comment 8 Scott Baker 2006-06-04 23:35:53 EDT
I can confirm that *just* installing alsa-driver-1.0.11 and rebooting fixed my
sounds issues with this card. When can we expect the new alsa version to end up
in yum? Alsa 1.0.11 has been released as stable.
Comment 9 Martin Stransky 2006-06-05 10:35:26 EDT
alsa-driver is a part of kernel so you can't update it by yum. It's work for
kernel guys...
Comment 10 Scott Baker 2006-06-05 10:53:02 EDT
I'm confused... if that's the case then how did installing alsa-driver as
described above fix my problem. I didn't make any changes to the kernel? It
seems to me that it's a alsa userspace driver issue, not a kernel issue. Unless
I'm misunderstanding.
Comment 11 Martin Stransky 2006-06-06 03:18:48 EDT
alsa-driver contains new kernel modules (with sound drivers) for your kernel and
you can install them from user-space....
Comment 12 Scott Baker 2006-06-06 11:24:01 EDT
Should we create a seperate bug for that then? Just to make sure the Kernel guys
are aware that the fix for *this* issue is something they need to do?
Comment 13 Martin Stransky 2006-06-07 12:30:48 EDT
Kernel guys aren't going to update alsa-drivers for fedora 5, new drivers will
come with shiny new upstream kernel, so it depends on kernel upstream. You can
report it there, but I think it's wasting of time...

Note You need to log in before you can comment on or make changes to this bug.