Bug 186213 - hp-setup errors looking for fax files
hp-setup errors looking for fax files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 189024 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 04:50 EST by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 04:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-03-22 04:50:18 EST
Description of problem:
Setting up a fax capable device (HP Color LaserJet 2840 in this case) using
hp-setup causes an error.

Looking at the spec
(http://cvs.fedora.redhat.com/viewcvs/rpms/hplip/FC-5/hplip.spec?rev=1.52&view=auto)
it appears that the removal of the Fax files was intentional:
# Don't package hpfax yet.
rm -f %{buildroot}%{_libdir}/cups/backend/hpfax
rm -f %{buildroot}%{_datadir}/cups/model/HP-Fax*

However, I don't believe that this is sufficient.  Unless I'm mistaken, you also
need to edit models.xml and change <fax type="1"/> to <fax type="0"/> for each
fax capable printer or it will look for the fax PPD file and print an error.

Also, what about /usr/bin/hp-sendfax?  How useful is that if faxing is disabled.
 It gives errors as well (because there is no fax queue).

Version-Release number of selected component (if applicable):
hplip-0.9.8-6

How reproducible:
Always

Steps to Reproduce:
1. hp-setup a fax capable device
2. hp-sendfax
3.
  
Actual results:
This is the last portion of the printer setup:
FAX QUEUE SETUP

Please enter a name for this fax queue (m=use model
name:'HP_Color_LaserJet_2840_fax'*, q=quit) ?
 Using queue name: HP_Color_LaserJet_2840_fax
 [ERROR]: Unable to find HP fax PPD file! Please check you HPLIP installation
and try again.


Expected results:
No error or even better, a working fax device.

Additional info:
Comment 1 Bernard Johnson 2006-03-22 05:00:24 EST
Actually, upon further inspection, there is a
/usr/share/hplip/fax/ppd/HP-Fax-hplip.ppd file, however, hp-setup is looking in
/usr/share/foomatic/db/source/PPD/HP/color_laser/ for the file.  This can be
confirmed by copying the ppd file and running hp-setup.
Comment 2 Tim Waugh 2006-03-27 12:59:46 EST
How about with the test update?

https://www.redhat.com/archives/fedora-test-list/2006-March/msg01594.html
Comment 3 Bernard Johnson 2006-03-27 13:13:58 EST
No, same problem.

Also, rawhide has the same problem (as you probably expected by this point)
Comment 4 Bernard Johnson 2006-03-27 14:35:36 EST
Is this a clue that there should be a symlink from
/usr/share/foomatic/db/source/PPD/HP/color_laserjet/HP-Fax-lplip.ppd to
/usr/share/hplip/fax/ppd/HP-Fax-hplip.ppd ??

http://hpinkjet.sourceforge.net/updates.php#rel099
22. HPLIP now installs HP-Fax-hplip.ppd independent of HPIJS. HPLIP installs
HP-Fax-hplip.ppd into $(datadir)/HP directory, but HPIJS creates the symlink
from cups/model/foomatic-ppd to $(datadir)/HP.
Comment 5 Bernard Johnson 2006-04-14 03:50:08 EDT
It seems the config file points to a non-existant directory.  This change allows
the ppd for the fax to be found and the fax queue to be setup:

--- hplip.conf.orig     2006-03-24 10:37:14.000000000 -0700
+++ hplip.conf  2006-04-14 01:34:41.000000000 -0600
@@ -15,7 +15,7 @@
 [dirs]
 home=/usr/share/hplip
 run=/var/run
-ppd=/usr/share/ppd/HP
+ppd=/usr/share/hplip/fax/ppd

 # Following values are determined at configure time and cannot be changed.
 [configure]
Comment 6 Bernard Johnson 2006-04-14 20:41:58 EDT
Sorry, I didn't notice there was a new rpm in updates-testing.  I installed
hplip-0.9.10-1.2 and I see now that you've moved the ppds to match the path in
the hplip.conf file.  Now my FC-5 system has the same problem (bugzilla #189024)
as my rawhide system.
Comment 7 Bernard Johnson 2006-04-17 12:41:06 EDT
*** Bug 189024 has been marked as a duplicate of this bug. ***
Comment 8 Bernard Johnson 2006-04-17 12:46:42 EDT
Tim, I think this all boils down to the PPD files must all reside in some
central location, be that the foomatic directory, or a /usr/share/ppd directory.
 Since the hplip file now only points to the /usr/share/ppd directory that
contains the HP-Fax ppd file, that is all that can be found (which was why I
filed #189024).  If I change the path in my hplip.conf to point to
usr/share/foomatic/db/source/PPD directory, and then symbolically link my HP-Fax
ppd file to somewhere in that structure (I used
/usr/share/foomatic/db/source/PPD/HP/all_in_one), then everything works great
and both ppd files are found as they should be.
Comment 9 Tim Waugh 2006-04-18 13:43:09 EDT
Okay, let's try hplip-0.9.10-1.3.
Comment 10 Bernard Johnson 2006-04-18 23:06:50 EDT
[bjohnson@localhost ~]$ rpm -q hplip
hplip-0.9.10-1.3
[bjohnson@localhost ~]$ rpm -ql hplip | grep Fax
/usr/share/hplip/fax/ppd/HP-Fax-hplip.ppd
[bjohnson@localhost ~]$
Comment 11 Tim Waugh 2006-04-19 04:08:56 EDT
It's in the hpijs package.
Comment 12 Bernard Johnson 2006-04-19 04:31:14 EDT
I thought I had looked there too, but I was mistaken.  Anyway, I cleared all my
cups queues, ran hp-setup, and added both a printer and a fax with no problem
whatsoever.  Cake.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.