Bug 186221 - Anaconda hangs on end of install when writing kickstart file
Summary: Anaconda hangs on end of install when writing kickstart file
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: powerpc Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 189001 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 11:18 UTC by Ingo Schaefer
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 21:17:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ingo Schaefer 2006-03-22 11:18:30 UTC
Description of problem:
After doing a normal http network install, anaconda hangs while writing
kickstart file. Given kill -9 anaconda exited with "install terminated
abnormally", umounting everything and rebooting. Rebooting went fine.
Looking to /root/anaconda-ks.cfg it is empty (0 Byte)

Version-Release number of selected component (if applicable):
Fedora Core 5 release date rescue cd for ppc

How reproducible:
Only tried once.

Steps to Reproduce:
1. Install as usual
2.
3.
  
Actual results:
Graphical Environment seems to hang, changing to the text consoles show he was
past the "install boot loader" step and changed to "writing kickstart file"

Expected results:
Anaconda should write the kickstart file and show the "success" screen

Additional info:
MacOS X and ubuntu linux are already installed on the machine.

Comment 1 Jeremy Katz 2006-03-22 15:57:04 UTC
What processes were running?  Were there any error messages from the kernel on tty4?

Comment 2 Ingo Schaefer 2006-03-22 16:09:16 UTC
Hello Jeremy,

seems you are involved in nearly all components...

Besides the normal kernel processes there was the X-Server, the mini-wm and two
python processes running, both with some -m option set and running anaconda

Nothing else.

I don't remember any unusual kernel messages on tty4 but I unfortunately don't
have any detailed log file from that.

Comment 3 Chris Lumens 2006-06-02 17:48:22 UTC
Can you test with Rawhide or FC6test1 and let me know if this is still happening
for you?  I've done a lot of kickstart installs and have not run across this bug
yet.

Comment 4 Ingo Schaefer 2006-06-02 19:26:01 UTC
Hello Chris,

unfortunately I only have one machine with ppc around. I'll try next week to get
another one to test this with.

But: It was _no_ kickstart install. It was interactive and anaconda crashed/hang
when writing the kickstart file (you know: to install more machines the same way
later)

Regards,
Ingo

Comment 5 Paul Nasrat 2006-07-17 22:09:27 UTC
*** Bug 189001 has been marked as a duplicate of this bug. ***

Comment 6 Chris Lumens 2007-02-23 17:00:31 UTC
Is this still a problem in Fedora 7 test 1?  Lots of code has changed around in
this area lately and it's likely we have inadvertently fixed whatever was broken.

Comment 7 Red Hat Bugzilla 2007-06-12 03:07:14 UTC
requested by Jams Antill


Note You need to log in before you can comment on or make changes to this bug.