Bug 186225 - message from syslogd in FC5 kernel: Disabling IRQ #17
message from syslogd in FC5 kernel: Disabling IRQ #17
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-03-22 06:59 EST by Motor
Modified: 2008-01-19 23:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-19 23:39:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Motor 2006-03-22 06:59:55 EST
Description of problem:
Upgraded a working FC4 system to FC5. I am now getting a strange message from
syslogd at any open terminal window:

Message from syslogd@konishi at Wed Mar 22 11:46:58 2006 ...
konishi kernel: Disabling IRQ #17

running dmesg, gives this:

irq 17: nobody cared (try booting with the "irqpoll" option)
 [<c01389ab>] __report_bad_irq+0x2b/0x69     [<c0138b6c>] note_interrupt+0x183/0x1af
 [<c01384c6>] handle_IRQ_event+0x23/0x4c     [<c0138589>] __do_IRQ+0x9a/0xcd
 [<c0104bde>] do_IRQ+0x5c/0x77     =======================
 [<c010358e>] common_interrupt+0x1a/0x20
 [<c0101dec>] default_idle+0x2b/0x53     [<c0101e4e>] cpu_idle+0x3a/0x4f
 [<c03a26a3>] start_kernel+0x28c/0x28e    <3>handlers:
[<e0919589>] (snd_cmipci_interrupt+0x0/0xe9 [snd_cmipci])
Disabling IRQ #17

I tried playing video after seeing this message, and the audio still seemed to
work. I further tried booting with the irqpoll option (as suggested in the dmesg
info) to see what happens... and during playback of a video, the sound began
looping the last half second and the machine was unresponsive requiring a reset. 

From /etc/sysconfig/hwconf:

driver: via686a
desc: "VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]"
vendorId: 1106
deviceId: 3057
subVendorId: 1458
subDeviceId: 0000

desc: "VIA Technologies, Inc. VT8363/8365 [KT133/KM133]"
vendorId: 1106
deviceId: 0305
subVendorId: 1458
subDeviceId: 0000

desc: "C-Media Electronics Inc CM8738"
vendorId: 13f6
deviceId: 0111
subVendorId: 13f6
subDeviceId: 0111

Version-Release number of selected component (if applicable):
Version     : 2.6.15 
Release     : 1.2054_FC5 

How reproducible:
Every reboot -- it takes a few minutes to happen.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Motor 2006-03-23 06:58:19 EST
I said above that the audio works... but after using the machine for a couple of
days, I realise that this isn't strictly true. There are occasional sound drop
outs while playing... and once mplayer has finished playing a video clip, the
last half second of sound repeats over and over again for a couple of seconds
before finally exiting. I don't believe this is a problem with the video clip,
or mplayer... since the clip played fine before the upgrade and mplayer was not
upgraded during the move from FC4 to FC5 (it was compiled from source). I can't
say for sure whether this is related to the above syslogd message, but I thought
it worth noting because it further suggests that something has broken in this
sound driver.
Comment 2 Motor 2006-03-25 11:03:57 EST
After a few days use, I've had a number of lockups requiring the use of the
reset button. In response, I tried installing the most recent FC4 kernel onto my
FC5 system:


After rebooting, the system works perfectly with no sound problems and no
lockups. That would seem to confirm that something has seriously broken in the
driver for this card in the FC5 kernel.
Comment 3 Dave Jones 2006-10-16 14:26:30 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Jon Stanley 2008-01-19 23:39:57 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.