Bug 186233 - Anaconda text mode broken for languages other than "us"
Anaconda text mode broken for languages other than "us"
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
http://ninan.info
:
: 186672 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 08:53 EST by Christian Kalkhoff
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 14:57:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Kalkhoff 2006-03-22 08:53:41 EST
Description of problem: 
It is impossible to use the text mode installer in a language other than us 
english. 
 
 
 
Version-Release number of selected component (if applicable): 
Fedora Core 5 DVD Images (x86 and x86_64 tested) 
 
 
How reproducible: 
Start installer in text mode using "linux text" on the syslinux shell, boot 
into anaconda and select language "German".  
 
When coming to partitioning only a "blue-screen" (Hehe) is drawn, pressing F12 
let you delete all partitions but there are no widgets to configure anything. 
The anaconda log states that there were no screens found. 
 
 
Steps to Reproduce: 
1. Enter linux text on boot prompt (syslinux) 
2. Select language "german" or probably any other in anaconda 
3. Try to proceed installation to after "Reinstall" fedora core 
   
Actual results: 
Blue curses screen without content instead of the partition tool 
 
 
Expected results: 
Partition tool 
 
 
Additional info: 
Work around is to use "us" as language for installation. Since FC5 it is 
possible to installation "Languages" in post-installation so that shouldn't be 
such a matter.
Comment 1 Chris Lumens 2006-03-27 11:18:17 EST
*** Bug 186672 has been marked as a duplicate of this bug. ***
Comment 2 David Cantrell 2006-09-13 14:57:41 EDT
Language support other than English in text mode is really difficult in
anaconda.  We have limited screen real estate, which is a problem for languages
like German.

We do our best to make sure it works and we still offer text mode German
intallations, but you would be much better off doing either a graphical
installation.  If you don't have a display on the system, try a VNC install
where you can run the graphical installer from another host.  Even better than
all of that is a kickstart install which isn't even interactive.

Note You need to log in before you can comment on or make changes to this bug.