Bug 186288 - None of the <Fn> <f#> key combos work on the Sony Vaio VGN-FS790B.
None of the <Fn> <f#> key combos work on the Sony Vaio VGN-FS790B.
Status: CLOSED DUPLICATE of bug 186285
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
NeedsRetesting
: Desktop
Depends On:
Blocks: 183410
  Show dependency treegraph
 
Reported: 2006-03-22 13:48 EST by Suzanne Hillman
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 13:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-03-22 13:48:40 EST
Description of problem:
None of the <Fn> <f#> key combos work on the Sony Vaio VGN-FS790B. I tried
changing what seemed to be appropriate settings (hot keys stuff) in the BIOS,
since it was strange that none at all were working, with no change in behavior.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2054_FC5

How reproducible:
Always

Steps to Reproduce:
1. Get a Sony Vaio VGN-FS790B with FC5 Gold on it.
2. Try pressing any of the <Fn> <F#> keys, such as mute, change between
displays, brightness and volume in/decreases, and suspend.
  
Actual results:
Nothing happens.

Expected results:
At least some, if not all, of these keystrokes should work.

Additional info:
Comment 1 Takaki Hiroshi 2006-03-24 09:37:31 EST
SONY VAIO PCG-N505A has same problem. At least Fn+F5(LCD brightness) and
Fn+12(hibernate) worked fine with FC4 probably without sonypi module.

If I load sonypi, I can set brightness by spicctrl with FC5.
Comment 2 Dave Jones 2006-10-16 13:36:56 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Christopher Aillon 2006-10-30 14:00:47 EST
Problem still exists in FC6 final.
Comment 5 Hezekiah M. Carty 2007-02-04 20:45:19 EST
I also have this problem on a Sony Vaio VGN-S260 laptop.  Tested with FC5 and
FC6 final, and FC7test1 releases.

Everything else works wonderfully, including suspend to disk and RAM, so this is
the last remaining roadblock for Fedora on here...
Comment 6 Bastien Nocera 2007-04-30 13:31:10 EDT
The kernel bits will work just fine if you use devel, as udev should load
sonypi, and sonypi will translate those events to keys such as KEY_FN_F1.

Now, do those appear properly in xev nowadays?

Closing as a dupe of 186285, as the S1/S2 keys are handled by the same piece of
code as the Fn+ combos.

*** This bug has been marked as a duplicate of 186285 ***

Note You need to log in before you can comment on or make changes to this bug.