Bug 186321 - i810 driver hangs system
i810 driver hangs system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-22 16:37 EST by Peter Dawes
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 09:57:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci (1.74 KB, application/octet-stream)
2006-03-22 16:37 EST, Peter Dawes
no flags Details
X logfile (58.82 KB, text/plain)
2006-03-22 16:39 EST, Peter Dawes
no flags Details
xorg.conf file (2.65 KB, text/plain)
2006-03-22 16:39 EST, Peter Dawes
no flags Details
output of lspci (properly uploaded...) (1.74 KB, text/plain)
2006-03-22 16:44 EST, Peter Dawes
no flags Details
Log with option "nodri" (56.12 KB, text/plain)
2006-03-24 09:38 EST, Peter Dawes
no flags Details
Log from not loading DRI (55.64 KB, text/plain)
2006-03-24 09:39 EST, Peter Dawes
no flags Details
X server log with option "noaccel" (55.05 KB, text/plain)
2006-03-24 09:40 EST, Peter Dawes
no flags Details
X server logs (92.86 KB, text/plain)
2006-03-29 10:17 EST, Ian Chard
no flags Details
self explanatory. This was with vesa driver test. (11.85 KB, text/plain)
2007-03-15 22:01 EDT, Leslie Satenstein
no flags Details
Log from last run (11.85 KB, text/plain)
2007-03-15 22:03 EDT, Leslie Satenstein
no flags Details
self explanatory. This was with vesa driver test. (11.85 KB, text/plain)
2007-03-15 22:18 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Peter Dawes 2006-03-22 16:37:51 EST
Description of problem: 
System hangs when using this driver

Version-Release number of selected component (if applicable):
1.4.1.3-3.1

How reproducible:
Every time...

Steps to Reproduce:
1. Start X using the i810 driver.
2. Use system for a while (not always necessary).  It will always hang at logout
if it gets that far.
3. System hangs - totally unresponsive to keyboard, mouse or network.
  
Actual results:
Hung system - needs full powercycle.

Expected results:
Functional system...

Additional info:
Pentium D 830, Intel motherboard D945GCZ with integrated 945G graphics
controller.  I'll attach Xorg.0.log, lspci outputs and the xorg.conf
Comment 1 Peter Dawes 2006-03-22 16:37:51 EST
Created attachment 126508 [details]
Output of lspci
Comment 2 Peter Dawes 2006-03-22 16:39:19 EST
Created attachment 126509 [details]
X logfile
Comment 3 Peter Dawes 2006-03-22 16:39:49 EST
Created attachment 126510 [details]
xorg.conf file
Comment 4 Peter Dawes 2006-03-22 16:44:32 EST
Created attachment 126511 [details]
output of lspci (properly uploaded...)
Comment 5 Mike A. Harris 2006-03-24 03:34:16 EST
Put 'Option "nodri"' in the device section of the config, and reboot and
start the X server.  Note if the problem is still reproduceable, and if so,
try commenting out the 'Load "dri"' line and rebooting again and noting if
the issue still remains.

Next, try using:  Option "noaccel" in the device section.

Do any of these options prevent the problem from occuring?
Comment 6 Peter Dawes 2006-03-24 09:38:50 EST
Created attachment 126627 [details]
Log with option "nodri"
Comment 7 Peter Dawes 2006-03-24 09:39:49 EST
Created attachment 126628 [details]
Log from not loading DRI
Comment 8 Peter Dawes 2006-03-24 09:40:34 EST
Created attachment 126629 [details]
X server log with option "noaccel"
Comment 9 Peter Dawes 2006-03-24 09:41:06 EST
Mike - I've tried all those options, in sequence.  Problem still happens -
system hangs as soon as I try to log out.  It looks like it's hanging as it
tries to re-start the server, but I can't be sure about that.  I'm attaching the
logs from each try.
Comment 10 Ian Chard 2006-03-29 10:17:47 EST
Created attachment 126991 [details]
X server logs
Comment 11 Ian Chard 2006-03-29 10:19:02 EST
See above logs, and note the "INVALID MEM ALLOCATION" and "ADVANCE_LP_RING:
outring (0x2f) isn't on a QWord boundary" messages.

A quick Google search for these reveals that many other distros are having
exactly this problem.
Comment 12 jonathan baron 2006-05-21 07:55:10 EDT
I'm not sure that this is the same problem, but on a Dell GX620
D 830, Intel GMA950 video, Dell 2405FPW monitor), the i810 driver
worked only at very low resolution, and then it crashed whenever
I logged out of Gnome, or try to kill X.  The last message in
/var/log/messages before the crash was always
[drm] Initialized i915 1.4.0 20060119 on minor 0
The X server logs did NOT have the invalid memory allocation
entry.

Also, FWIW, I seem to be able to get things to almost work by
using the vesa driver instead of i810.  (Still problems getting
1920x1200, which looks like 1600x1200 even though xdpyinfo says
it is 1920x1200.  I don't think I'll report a bug about this
because vesa is the wrong driver.)
Comment 13 Need Real Name 2006-05-24 18:29:13 EDT
I am experiencing what looks to be a very similar issue, also on a Dell GX620
(see bug 192885)
Comment 14 Adam Jackson 2006-08-17 21:51:49 EDT
Can anyone reproduce this with xorg-x11-drv-i810 1.6.0 or later?
Comment 15 Peter Dawes 2006-08-18 13:59:42 EDT
(In reply to comment #14)
> Can anyone reproduce this with xorg-x11-drv-i810 1.6.0 or later?

Is there a package built against Core 5 anywhere?  I've downloaded the source
from x.org, and will try building that, but...
Comment 16 Matěj Cepl 2006-10-24 10:15:57 EDT
I have here Dell Inspiron 2200 with

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)

(PCI ID 8086:2792)

and just with default configuration

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        VendorName  "Videocard vendor"
        BoardName   "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics
Controller"
EndSection

it works without problems (no Composite though).
Comment 17 Matěj Cepl 2006-10-24 10:19:31 EDT
Sorry, fortgot to add the most important. My driver is

xorg-x11-drv-i810-1.6.0-2
Comment 18 Leslie Satenstein 2006-12-02 20:53:59 EST
I have the identical problem to the above. My motherboard is an Intel d945gnt
with integrated i810 video. I have updated the bios to 11/9 version and the
problem persists. However, this time I have noted that occasionally the blow up
is in the bios.

My x11 log only indicated a new instruction for which there is no driver
equivalent.  This note is being written from my usable windows xp system. Please
read my earlier comments on this same subject.

The X11 files with vanilla fc6 (oct 24) are more stable then the Nov 20 release
of 4 patches for x11. 

There was a chance that the problem was actually outside of the i9810 in Hal or
in the font rendering patch that was released at end November.

Comment 20 Leslie Satenstein 2007-03-15 20:43:03 EDT
March 15th (ides of March).
System crash when logon screen presented.

My mother board is from the same family as the above reported problem.
I am using the 32 bit I386 version both with and without XEN.

When I removed the exclude=*xorg* from my yum.conf file, here is the status.
System boots until logon screen is presented. I can follow all the messages 
Immediately when the logon screen being presented, it is there for a splint
second and then there appears to be a bad branch to the bios, as if a address
segment register was initialised to zero. I end up with a nice Intel mother
board message and no keyboard or mouse. It takes a system reset to reboot to the
same position where the bad branch reoccurs.


Here is my configuration.
Intel d945gnt mother board, 1 gig memory, ide 200g hard drive, dual core intel
d930, fc6 xen or non xen version (also current to patches as of March 12th).
The graphics is provided by the on-board hardware, with the default 256k shared
memory). 

This is a two hard disk system, where each disk is bootable. Disk2 is a 250gig
sata, on which fc6 also suffered with the same problem until, immediately after
October 24th FC6 re-install. Immediately following that install and before
updates I added the parameter exclude=*xorg* to the yum config and then
installed all updates.  With the xorg exclude=, system boots and operates as
expected. 

Since then, on Fedora system 2 (the sata drive), I permitted the *.drv files to
be installed. There does not appear to be any problem with the *.drv files.

My initial complaint was filed for the xorg.rpm files released about November
20th. The xorg rpm files on or about that date that may contain the bug and
could be one of:

xorg-x11-server-Xnest-1.1.1-47.7.fc6.i386.hdr
xorg-x11-server-Xorg-1.1.1-47.7.fc6.i386.hdr
xorg-x11-server-sdk-1.1.1-47.7.fc6.i386.hdr
xorg-x11-server-Xvfb-1.1.1-47.7.fc6.i386.hdr
xorg-x11-xinit-1.0.2-15.fc6.i386.hdr

I am going to use the system rescue and eliminate the logon screen (gnome) from
being the cause. and will update this bug report following this exercise.

As indicated, the system crashes when the logon screen is presented.
I will also report on my success with "nodri"

In the crash, the bios display, in color (Intel(R) 82945G Chipset family PCI
Accelerated SVA 2006/...  is presented.

Again, my way to bypass the problem is to just remain with the xorg software
that was distributed with FC6 vanilla DVD.  FYI. The unofficial FC6 respin
crashes at the same point.  2nd FYI, testing takes hours. so, I may just
reinstall FC6 Oct 24th version, block all xorg updates, and enjoy FC6 until FC7
is out.  The live CD for FC7 appears to work fine....

 
Comment 21 Leslie Satenstein 2007-03-15 21:34:17 EDT
Here is a status report (1 hr after prev posting). System with nodri did not
crash immediately, only X mouse showed on screen. Ctl-alt-bkspace gave me root
prompt, from where, the startx command seemed to lock system up.

I rebooted from 2nd system, renamed the xorg.conf and rebooted.  
The system arrived at the logon screen, showed me the bios message from the
onboard graphics card, and immediately gave me the logon prompt. I am writing
from the logon prompt.

I will do a sync, and logoff - reboot, and come back with the hopefully
encouraging news.

 
Comment 22 Leslie Satenstein 2007-03-15 22:01:38 EDT
Created attachment 150192 [details]
self explanatory.  This was with vesa driver test.
Comment 23 Leslie Satenstein 2007-03-15 22:03:25 EDT
Created attachment 150193 [details]
Log from last run
Comment 24 Leslie Satenstein 2007-03-15 22:18:45 EDT
Created attachment 150194 [details]
self explanatory.  This was with vesa driver test.

-rws--x--x 1 root root 1815124 Feb 28 16:34 Xorg	  Failing version
-rws--x--x 1 root root 1820676 Oct  5 00:05 /usr/bin/Xorg  

I have copied 2nd file to overwrite the smaller Xorg file.
Further details soon
Comment 25 Leslie Satenstein 2007-03-15 22:29:23 EDT
HORRAH HORRAH.  Replacing file1 with file 2 (The fc6 vanilla release Xorg
excutable solves the problem.

My second system is now stable. Hip Hip Horrah.  These feedback is as good as I
can get it, without opening up the code to find out what is missing. (new module
is smaller than older one).

This new module should get onto the respin cd/dvds. 
Comment 26 Leslie Satenstein 2007-05-09 21:57:15 EDT
This problem exists since FC5.  Note the temporary solution with fc6, and
absolutely no solution with fc7.  Almost 8 months to fix. Has any progress been
made.  I cannot use XEN with a computer purchased expressly to be able to do so.
Comment 27 Leslie Satenstein 2007-06-01 16:52:24 EDT
With FC7 golive (May 31st) XEN and Non XEN, I have not experienced any problems.
As far as I am concerned, it now works for me.

Thank you again.
Comment 28 Matěj Cepl 2007-07-03 09:52:24 EDT
Fedora Core 5 is no longer supported, please, could you reproduce this bug with
the updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX/INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 29 Peter Dawes 2007-07-10 13:00:33 EDT
Sorry, I don't have the hardware to test this available anymore.  Comment #27
seems to indicate this is fixed as of Fedora 7 though.
Comment 30 Matěj Cepl 2007-07-11 09:57:47 EDT
Closing per comment 27 and because we don't support the original reported
distribution.

Note You need to log in before you can comment on or make changes to this bug.