Bug 18638 - openssl src rpm fails build in python swig section (patch provided)
openssl src rpm fails build in python swig section (patch provided)
Status: CLOSED DUPLICATE of bug 18572
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 09:53 EDT by Graham Higgins
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-08 09:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Higgins 2000-10-08 09:53:29 EDT
# rpm -ba SPECS/openssl.spec
[ ... ]
+ pushd m2crypto-0.05-snap3/swig
/usr/src/redhat/BUILD/openssl-0.9.5a/m2crypto-0.05-snap3/swig
/usr/src/redhat/BUILD/openssl-0.9.5a
+ make INCLUDE=-I. -I../../include
'LIBS=-L/usr/src/redhat/BUILD/openssl-0.9.5a -lssl -lcrypto -lc'
'PYINCLUDE=-DHAVE_CONFIG_H -I/usr/include/python1.5
-I/usr/lib/python1.5/config'
swig -shadow -python _m2crypto.i
Generating wrappers for Python
cc -c -fpic -DTHREADING  -I. -DHAVE_CONFIG_H -I/usr/include/python1.5
-I/usr/lib/python1.5/config _m2crypto_wrap.c
_m2crypto_wrap.c:558:25: openssl/err.h: No such file or directory
[ ... ]
_m2crypto_wrap.c:2076:27: openssl/pkcs7.h: No such file or directory
make: *** [_m2crypto] Error 1
Bad exit status from /var/tmp/rpm-tmp.73931 (%build)

Here's a patch for the spec file:

diff -uNr openssl.spec openssl.spec.new 
--- openssl.spec	Tue Aug 29 15:26:46 2000
+++ openssl.spec.new	Sun Oct  8 14:40:29 2000
@@ -141,7 +141,7 @@
 # Build the python extensions.
 pushd m2crypto-%{m2crypto_version}/swig
 make \
-	INCLUDE=-I. -I../../include \
+	INCLUDE="-I. -I../../include" \
 	LIBS="-L${TOPDIR} -lssl -lcrypto -lc" \
 	PYINCLUDE="-DHAVE_CONFIG_H -I/usr/include/python1.5
-I/usr/lib/python1.5/config"
 	PYLIB=/usr/lib/python1.5/config
Comment 1 Nalin Dahyabhai 2000-10-10 14:00:54 EDT
This one's already fixed in the build tree.  The python bindings were added in
later in the cycle, after the -devel package from earlier releases had been
installed on build machines.  Thanks!

*** This bug has been marked as a duplicate of 18572 ***

Note You need to log in before you can comment on or make changes to this bug.