Bug 186380 - f-spot 0.1.10 crashes on cropping
f-spot 0.1.10 crashes on cropping
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 188244 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 04:26 EST by Gen Zhang
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 14:15:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gen Zhang 2006-03-23 04:26:19 EST
Description of problem:
f-spot crashes on trying to crop image

Version-Release number of selected component (if applicable):
0.1.10-1

How reproducible:
everytime

Additional info:
Output:
Starting new FSpot server

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:copy_from_unmanaged
(intptr,int,System.Array,int) <0xe>
in (wrapper managed-to-native)
System.Runtime.InteropServices.Marshal:copy_from_unmanaged
(intptr,int,System.Array,int) <0x19ade>
in System.Runtime.InteropServices.Marshal:Copy (intptr,byte[],int,int) <0x2e>
in PixbufUtils:Save (Gdk.Pixbuf,string,string[],string[]) <0x150>
in FSpot.JpegFile:Save (Gdk.Pixbuf,System.IO.Stream) <0x6a>
in Photo:SaveVersion (Gdk.Pixbuf,bool) <0x146>
in PhotoView:ProcessImage (bool) <0x368>
in PhotoView:HandleCropButtonClicked (object,System.EventArgs) <0x1d>
in (wrapper delegate-invoke)
System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
<0x461de1>
in GLib.Signal:voidObjectCallback (intptr,intptr) <0xc9>
in (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
<0x5cb9cc54>
in (wrapper managed-to-native) Gtk.Application:gtk_main () <0xb>
in (wrapper managed-to-native) Gtk.Application:gtk_main () <0xffffffffffffffd0>
in Gtk.Application:Run () <0x8>
in Gnome.Program:Run () <0xc>
in FSpot.Driver:Main (string[]) <0x6ca>
in (wrapper runtime-invoke) System.Object:runtime_invoke_void_string[]
(object,intptr,intptr,intptr) <0xffffffffc044f4ab>

Native stacktrace:

        f-spot(mono_handle_native_sigsegv+0x8d) [0x4e7c6d]
        f-spot [0x4b56b8]
        /lib64/libpthread.so.0 [0x379dc0cf40]
        /lib64/libc.so.6(memcpy+0x34) [0x379bd75b04]
        [0x402250fa]
Comment 1 Andy Burns 2006-04-07 09:14:18 EDT
*** Bug 188244 has been marked as a duplicate of this bug. ***
Comment 2 Gen Zhang 2006-04-07 09:21:10 EDT
Using the same spec file, and f-spot 0.1.11 from upstream, I don't get the
error. So this should be solved by matching upstream.

Note You need to log in before you can comment on or make changes to this bug.