Bug 18641 - Installation Fails
Installation Fails
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 10:05 EDT by Karim
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 10:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karim 2000-10-08 10:05:23 EDT
Hello Everybody

Does anybody out there know how to solve the Traceback Error. I am sure 
everybody is familiar with it, if that is not true check 17994 and 18163 
which I submitted, the former includes the text of the error. It occurs 
during the installation of Redhat at the "Reading Package Information"?

It is complaining about anaconda. I have tried everything possible to fix 
this problem. Including downloading all of the files from ftp.redhat.com 
instead of a different mirror ( I figured they are bound to have right 
files!) 

I also don't know why installation runs in text mode even though I request 
graphical mode.

I am installing from the hard drive which is an 15 GB hardrive partitoned 
4 for Linux and 11 for FAT32.

Machine Specifications:
PIII 650E overclocked to 884.
Asus CUSL2 m/board with 815e intel chipset
Nvidia Geforce2 MX video card
SB Live! Value
Fujitsu 15GB HD

Please let me know what can I do to resolve this problem.

Thank you in advance


ERROR MESSAGE:
+This is what the installer had to say about the error:
+
+Traceback (innermost last):
+ File "/usr/bin/anaconda.real", line 438, in ?
+ intf.run(todo, test = test)
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
+run
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
+line 33, in __call__
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
+getCompsList
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
+in readComps
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
+__init__
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
+readCompsFile
+ File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
+__getitem__
+KeyError: indexhtml
+
+Local variables in innermost frame:
+self: <comps.HeaderList instance at 82c4048>
+item: indexhtml
+
+ToDo object:
+(itodo
+ToDo
+p1
+(dp2
+S'method'
+p3
+(iharddrive
+HardDriveInstallMethod
+p4
+(dp5
+S'fstype'
+p6
+S'vfat'
+p7
+sS'isMounted'
+p8
+I1
+sS'fnames'
+p9
+(dp10
+
+<failed>
Comment 1 Michael Fulbright 2000-10-09 10:56:14 EDT
This is due to a corrupt downloaded image. Be sure to use the 'binary' ftp
option.

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.