This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 186438 - In kickstart , ignoredisk option doesn't work with the initlabel flag regarding initialization of drives
In kickstart , ignoredisk option doesn't work with the initlabel flag regardi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Reopened
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-03-23 11:13 EST by Olivier de Liocourt
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0215
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olivier de Liocourt 2006-03-23 11:13:56 EST
Description of problem:
There is an undocumented option(BZ 164787) called "ignoredisk --drives=sdb,sdc"
that can be passed in a KS file to ignore everything regarding the concerned
devices, which works well, excepted regarding the --initlabel option which tries
to initialize all drives visible to the machine.

Version-Release number of selected component (if applicable):
anaconda-10.1.1.37

How reproducible:
create a KS file with the options indicated above in it, and try to install
RHEL4 U3 on a brand new harddisk. The page regarding the initialization of the
drives which should be ignored come up for the ignored listed devices, but
should not.

Additional info:
It seems that the openDevices function in partedUtils.py is responsible of this
issue:
    def openDevices (self, intf = None, initAll = 0,
                     zeroMbr = 0, clearDevs = []):
        """Open the disks on the system and skip unopenable devices."""
        if self.disks:
            return
        for drive in self.driveList ():
            if drive in DiskSet.skippedDisks and not initAll:
                continue
            deviceFile = isys.makeDevInode(drive)


I replaced the 3 last lines above with:
           if drive in DiskSet.skippedDisks and initAll:
                DiskSet.skippedDisks.append(drive)
                continue
            deviceFile = isys.makeDevInode(drive)

It seems to fix the problem, but maybe I am wrong somewhere.
Comment 1 Chris Lumens 2006-03-23 15:15:34 EST
Fixed in Rawhide and will be in RHEL5.  If you need a fix for this in an update
release, we'll need to go through the procedure for getting it on the list for U5.
Comment 4 RHEL Product and Program Management 2006-08-18 12:24:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Peter Jones 2006-08-28 11:24:13 EDT

*** This bug has been marked as a duplicate of 198525 ***
Comment 12 Chris Lumens 2007-03-08 11:46:31 EST
Committed a fix to the RHEL4 branch.
Comment 13 Suzanne Yeghiayan 2007-04-11 17:38:47 EDT
While a fix was committed to CVS, it was not built in brew and thus did not make
it into RHEL 4.5.
Moved to 4.6 since it is too late to resolve in 4.5.
Comment 16 Peter Jones 2007-04-13 16:40:34 EDT
should be fixed in anaconda-10.1.1.63-4 .
Comment 19 Red Hat Bugzilla 2007-05-01 13:19:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0215.html

Note You need to log in before you can comment on or make changes to this bug.